Editing broken again


#1

The old editing behaviors are back in 4841-4853: entity flinging, entities snapping back and forth scores of meters on the tiniest amount of mouse pointer movement, cannot often select an entity at all. I just flung half my domain to smithereens, so now restoring from backups.

I stopped all scripts, then started defaults.js in case there was a script conflict. If there is conflict, then it is inside defaults.js

I tried going back to a known working version 2831 but of course that no longer works because of the big packet-interface change. so, taking a break from HF.


#2

I have some weird problems too when i try to edit entity… Sounds like i have the same problems as you.

  • I cannot move the entity up or down with the inworld arrow anymore. the entity moves in the X or Z direction.

  • Trying to select entity seems much harder now,

  • The selection lines sometimes don’t know what the want (to select)

  • Camera seems a bit unstable to in edit mode.

So, editting entitiies is not fun for now. It where better.


#3

Windows 2853 editing issues.
Selected objects does not show in properties.

I can select an object but the properties show as empty, like I dont have anything selected.

Cant do anything.


#4

Aye somethings broken, wonders what happened and more importantly who we can blame :smiley:


#5

@Thoys , but please get this fixed. I come in all excited, with something I created, then leave frowning because I can’t put the object where I want to put it…and, hence, want to put it somewhere, er, …


#6

We have a fix coming.


#7

There’s an issue where the ray picking is randomly broken when the mirror is open. Fix here: https://github.com/highfidelity/hifi/pull/5395

It probably won’t be merged until at least a little later today, so a temporary fix is to close your mirror.


#8

Confirmed that workaround works.

It also explains why WEB entities were wonky - touch events totally spastic.
Thanks for the eventual fix.


#9

The fix is now live.


#10

Editing seems to be broken again with 3427.

After selecting an entity and then clicking on Entity Properties, the properties tab shows No Selection, so nothing can be edited.


#11

After Updating Interface to 3427
No field details (posn, dim etc.) shown for Entities
Tried updating Stack Manager (win 93 latest) “Error Opening file for writing” +Abort


#12

Now seems to be fixed on 3428