Empty edit Window in Interface


#1

Hello,

The Edit window is empty as you can see on the screenshot. Is it a bug I should report or a problem on my machine ?

Interface last version on Mac Os X El Capitan 10.11.4

The domain-server is installed on a server with Ubuntu 14.04

Thank you


#2

Looks pretty bugworthy. I’ll log it. Thanks!


#3

Are you sure you use the latest scripts. because your toolbar is still at the right side. and if you did not add it back the goto button would not be on the screen too. With the latest 4825 version i use not allow me to place the edit buttons at that side. (part get out of screen on the right side.)


#4

I have version 4825. I’ve just tried to remove all the preferences files from Application support folder and the cache, the problem is still there.

@Caitlyn : I haven’t found where I should go to report a bug :slight_smile:


#5

Now you started with a fresh config. Do you now have a different button layout on your screen ? The only two visible button (unless changed again) are examples and edit If the buttons are still the same as on the first image. It’s still possible you use for some reason the wrong defaultscripts.js from the internet and not the new one from your local hdd. It happend to me too a while ago.

Not have interface in range, but check in the settings what default scripts get loaded and from where.


#6

When I look at the logs, I see that :

http://s3.amazonaws.com/hifi-public/scripts/defaultScripts.js
http://s3.amazonaws.com/hifi-public/scripts/edit.js

In the preferences, I see Look for script in this directory :

/Users/Laurent/Desktop/script.js

This is not a directory, and I can’t find script.js on my computer. I’ve tried to change for another directory, but I can’t. I’ve chosen a directory with script.js inside, but I see it empty in Interface, and I can’t select it as the place to look for scripts.

I’ve sent an email to "bugs@highfidelity.io".


#7

Now behind the pc, change the default script directory to the one inside the highj fidelity scripts directory. change the path in the general settings. it need to be somethinge like this,

C:\Program Files\High Fidelity\scripts\defaultScripts.js


#8

It’ better, thank you. I’ve found the scripts repertory in “/Applications/High Fidelity/Interface.app/Contents/Resources/scripts”. Now I have the Edit window. I just miss the Places window to go to another domain.


#9

Places you can load by go to the option Edit in the menu then running scripts and search for directory.js and load that.


#10

Perfect. Thank you :smile: