FBX Export 3DS Max Animation Oddity


I have a few baked animated theme park attractions I’ve made with Max 2012. When I export to FBX, the result is what looks like the first 20 or so frames just repeating rapidly, as opposed to the full animation which is 4000 frames. I tried exporting as a 2012 and 2013 FBX file.

Now, If I export as a DAE, then convert it using Autodesk’s seperate FBX converter, the animation works perfectly in High Fidelity. While that may be a quick solution, I was hoping to eliminate that extra step. Any ideas?

Also: I’m assuming an Avatar can’t sit on a moving object yet…and move with it, correct?


Did you set the start and end frames in properties in hifi?


Thanks. I tried 0 - 4000, and also left it the way it was. Same results. The DAE converted file didn’t need to have any frames adjusted in HiFi. It just worked with the default settings in the animate options.


hmmm and the anims only have rotations , no scaling or stuff?


Only rotations in the animation. Wondering if it has something to do with the FBX exporter inside max itself.


FBX File Format > FBX 2014/2015 are the versions that @Caitlyn suggests for pbr so maybe those are the ones the devs are focused on
mentioned here in a more pbr way


@thoys and @Piper.Peppercorn had a rollercoaster doing that a while back maybe they can elaborate on how


Oh, that’s interesting ('bout the 2014/2015 versions). It’s odd that the independant 2013 converter manages to get DAE to FBX animated meshes working perfectly in hifi. I wonder if I can use a 2014 FBX converter for 3DS Max 2012. Thanks for the link - I’ll have to read up on Caitlyn’s info.

A rollercoaster? I have to see this! Do they have a spot to visit on hf?


By the way - problem solved. It had to do with the rotations in 3DS Max. I needed to change the rotation controller from Euler to TCB, then redo the keyframe animation from scratch. Now I can simply export as an FBX and animation/textures are perfectly intact.