FBX good color, wrong size. OBJ good size, no textures or color


#1

Blender and especially mesh is all drama at it’s own. With hifi it’s more work , you need to savae it in blender to obj, then convert it to fbx. To dioscover that the size is wrong.
If you use OBJ there or no colors or textures.

Uhhh. CooCoo. :wink: :smiley:

Or it end at 0,0,0 and you cannot do anything with it delete fails too.
We need to wait longer foir doing soemthing.


#2

I havent had any issues with FBX exporting in blender in the wrong size. Make sure that the export setting is set to 1, and that you are building to blender units (1 blender unit = 1 meter in FBX). Obj on the other hand comes in the absolutely wrong size and scale for me.


#3

Yes, check your units in Blender, they need to be set to metric, then look at the window that is shown with the “N” key, you will have your dimensions there.

Make sure the size is correct metrically, then export with 1 - 1 scale as Menithal suggests.


#4

The main confusion in here is that the Blender metric can make things too big with the Metric Scale.

So forexample, ozans blender file has 1 Blender unit = 0.01 Blender meter,
while the FBX translation is actually 1 Blender unit = 1 meter. So in total, the Blender conversion would be 100x the actual value for for ozans file.


This is a really important value to set for FBX export too if exporting with a different scale.


#5

Yup , done it checked it. diomensions are good. scale is 1.0 metric is set.
But still the fbx i need to scale 1000% up to have it correct. the OBJ is sofar i have seen correct in size. unless i make some error. mesh is not so friendly in use as SL build tools.
SO it’s plenty of headaces.


#6

Have you made sure to Apply>> Rotation& Scale? This will make any relative scale you have performed in object mode to be reset to 1. I do this with every model (in combination with setting metric units) and have had no problems with import.

Although, during one import of the London Eye, I did have to press “reset to original dimensions” within HiFi


#7

Hmm, i think i forgot how todo that in blender. it’s DAE that i made in SL. so technical things must be fine. Other problem could be that i need to convert the OBJ in the autoddesk converter to fbx. because the fbx blender is saving seems to give a not loading fbx.

I need to try more things…


#8

if it is an imported file it is -very- likely that the scale of the model it self is not proper:

To fix this, you can check the Left side menus dimensions field when the object is selected. To Apply the rotations and scale you have to use Apply >> rotation scale as @Captain.Oculus mentioned. You can find this by either pressing space and typing “apply visual transform” OR press ctrl + a and select “apply rotation and scale”.

The FBX exporter in Blender works fine. Its just that some of the features is not interpreted by HiFi correctly (mostly to do with armatures and vertex colors). Make sure to be using the latest version of it though. 2.74 brought in alot of fixes to it.


#9

I have a good day, today it worked with the fbx exported from blender. Also “apply rotation and scale” did possible invisible the trick. Now the chair is to big, but that i can change in blender.

I really need to make some flowcharts for blender, or am doomed.

Only getting it in the correct scale is failing. the size in high fidelity is bigger then i have set in blender.


#10

Both FBX and OBJ CONSTANTLY uploads a wireframe green box OR a totally white (aka textureless) build. Apparently it does not matter WHO makes the object, all uploads are useless. I’m getting a bit antsy because I have not been able to successfully find the problem. (I am suspecting something in the Hi Fi code itself is at fault)


#11

HI @Foxxe , send me your model and I will have a look.


#12

@Chris: You can see two inworld at Wilderness. (The garage is mine and the tree beside it is an import from the net.)


#13

Im having the same size issue with fbx exports/imports. In maya the model is huge but when i import it into hifi its so small my avatar could step on it.

I looked at the settings in maya for fbx and i dont see any advance settings at all. Im going to try reinstalling the plugin because the info i find online says there should be several different categories of settings for fbx in maya and i see none.


#14

Oh, forgot to mention. If the model it self is huge really huge, you may have to press the “reset to natural dimensions button” its downscale by default for what ever reason. If it doesn’t reset to its true size there and then, then something is wrong with the export scale used unfortunately not quite clear on how you set the scale when exporting from maya.


#15

Just thought I’d say that EVERYTIME I import the London Eye I have to “reset to natural dimensions” I believe it could be coded in the C++ as a sanity check.

I think to myself as if the code has a conscience, "…nearly 240 feet you say? hmmm, that certainly is a stupid human error… I’ll fix that for you… "

:smile:


#16

Yeah I found this quirk recently as well. It also happens sometimes when you click on the entity to begin editing/moving - it then shrinks down to 0.010 x 0.010 x 0.010. You then have to use the RESET TO NATURAL DIMENSIONS button.

It’s annoying as hell but I’ve learned that due to the lack of decent mouse control inworld with basic object dragging, I have learned to employ the edit window controls directly.