Frustrating bug. Interface not restore default playback device to orginal one after closing interface


#1

Am now 100% sure it’s interface that is screwing my default playback device.
When i start interface the playback device where set like this.


Now, when i used Interface.exe and i log out. I lose my audio.
I now know that interface is not restoring the playback device.
With that windows is staying in this setting that is complete wrong.


And this is lucky without running steamVR. That would make things only more complex. SteamVR or steam you only start when you need VR. after that you turn it off. I use the desktop version of high fidelity, for the simple reason that the steam version is always starting steam , also when you not need it. On top of that STeamVR can be extra drama with your audio settings.

It start to get boring, and sometimes you forget it to figure everytime out where my audio is and soemtimes you need to restart application to get it back after correcting playback device.

Required fix, remember the playback settings when you start interface and restore them when you close interface.

UPDATE: The header description where wrong.

ADD: The thing get stranger, because interface is set to use the same device for output as windows use as default playback device. And interface still thinks it need to change the default playback device inm window to a wrong settings.

I btw need to figure out why windwos is seeing 3 optical devices as playback.

Something changed in build 6358 ? Now the default device seems to stay. Not sure for how long.


#3

I think interface did changed my output device again. and i forget to set it back after close interface. With the result that today the playback device is wrong again. And you start to blame windows when it’s really interface.

Checked it again, it’s satill interface. This need a quick hotfix.

ADD: It also keeps strange that interface is ignoring it’s own settings. Not sure why it change the default playback device when you can set it in high fidelity itself. or steamVR is switching it


#4

I know what the problem is. It’s for sure interface that is handling things wrong.

What interface.exe is doing. It’s just starting parts of steamVR.
The following 3 programs get started by high fidelity. I double checked it and steamVR is starting the same ones.

Problem is that high fidelity is starting it as hidden / invisible application.
Because STeamVR get started, it’s changing the default audio playback device to the one that is set in steamVR.

Now the problem get bigger, that interface is starting steamVR. is mabye a valid reason i still do not like. BUT,, A blame interface complete for it that it’s not shutting steamVR that interface started nice and clean down when you close (or crash) interface.exe. With the result that your audio playback device never get restored to the orginal setting.

It’s still better to not start automatic steamVR at all, If i like todo that i click the icon, That is why i do not autostart to steamVR at boot. because it’s messing up your audio settings. It’s ok for the moments you use VR. But otherwise it’s only a disaster.

The result of on solution this behaivor with interface is that i switched steamVR back to use the correct dekstop audio device. That means i do not use VR anymore in High |Fidelity on events and meetings. I only use it to check my mesh creations. Because for that i do not need audio.

Finaly the audio hell is explained after months, it only got worse since beta 37

Also because this bad shutdown of interface and steamVR. It’s eating still resources after not using it. around 4% but i have seen it did go up to 14% i think after hibernate.


SteamVR get started when no Headset is connected (fail), it not start when connected (correct working)