Hand controllers ignored when using Oculus DK2 + SteamVR


#1

Hi folks,

I’ve come across an issue: when launching HiFi either from Desktop or SteamVR, it detects my Oculus DK2 as Oculus Rift and overrides SteamVR altogether. In fact, you can close SteamVR and HiFi will keep running nonchalantly.

This wouldn’t bother me at all if I wasn’t using an open source hand controller emulator called PSMoveService that allows to use cheap Playstation Move controllers and PS3Eye cameras for hand control with SteamVR.

Like this:

Already tried:

  • Using a previous Oculus runtime (HMD not detected by SteamVR).
  • Using no Oculus runtime (HiFi will not detect the HMD).
  • Using the “-vrmode OpenVR” commandline option with HiFi (nothing).
  • Various tinkering.

Is there a way to force HiFi to use SteamVR or at least make it use the SteamVR controllers with an Oculus HMD?


#2

it may not work but i was using this thing that allowed me to use the hydras with the rift to use vive software in steam

also had a google and found this


#3

Hi Judas, the last thing you posted is what I’m using. It works fine with The Lab and other pure SteamVR apps/games, but not with Hi-Fi, as it seems to be launching direct to the Oculus Rift and not using SteamVR.

It would be good if SteamVR could be forced in Interface somehow.


#4

Hm. this could have something do with the automatic detection of the HMD turning on the OpenVR solution.
Maybe a flag could be added to trigger this as well when the client is opened regardless of the HMD.


#5

Yes! I could do with a commandline flag that turns on OpenVR and hooks to the steam controller regardless of the HMD. Now a VR option panel with more debug options, that would be grand.


#6

I’ve been looking at the code on GitHub. Unfortunately I’m awful at C++. But for someone more familiar with the project wouldn’t be too difficult to have Interface list more than one HMD and let you choose between SteamVR and Oculus (or have SteamVR controllers work simultaneously with Oculus although this would probably be a mess).


#7

If you have a github account, I suggest raising an issue ticket there to catch the right devs on the subject. They occasionally check the forums but git should be the way to reach them faster with such.


#8

I do have a GitHub account and I have contributed to another project before, so I made a post on the issue tracker. Thanks for the suggestion :smiley:


#9

Although it’s not officially supported, there is a debug mode that you can enable to have the High Fidelity Inteface use the OpenVR sdk instead of Oculus, when using the oculus. This is available by setting the HIFI_DEBUG_OPENVR environment variable.

The current beta has a bug in it, that causes this to judder, but a fix has been merged with the latest dev build (and will be in the next beta) – that allows this mode to operate without judder.