Has the internal script editor gone? [solved]


#1

I’ve just started looking into scripting, using the tutorial here, which talks about a script editor in the Edit menu (shortcut Alt+S). Despite enabling Advanced and Developer menus, I can’t find this option, or any similar option. Has the editor been removed in favour of external editing?

Also, I’ve tried loading a basic “hello world” script created with an external editor, copied verbatim from that wiki page, but while I’ve been able to load it into the “running scripts” window, I don’t know where to look for output. Nothing appears in the “scripting console” window when I use the JS “print” command.

Scripts do run - I can load the butterflies and cows in the examples just fine, and see butterflies and cows in-world.

So essentially I’m not even at the position of being able to run a basic “hello world” script, either because I’m looking in the wrong place for tutorials and documentation, or because the available tutorials are out of date, or maybe because I’m being a bit stupid and missing something obvious.

Help me out here, please!


#2

u can run scrips still in the console which will do the hello world thing

and yay look at me answer a scripting question omg what have i become


#3

Thanks Judas - yes, if I type the source code into the console it runs. But how can I attach a script to an entity and communicate with it? Or any of the modes (client/server/etc) that HF supports?

I feel like I’m missing a vital tutorial here, and I’m completely stuck.


#4

ah if u upload the script somwhere public u load the script from its url, the models have a url window thing


#5

So each time I make a change to a script I have to FTP it to a public space before I can run it?

Isn’t there a quicker workflow than that? I was hoping to be able to edit the scripts on my hard disk and test and run from there.


#6

yes u can load it from ur desktop to run it locally
um


#7

Ah, OK, so I was kind of on the right track.

But how do you view the script’s output? By that, I mean if I have: print(“fubar”), where does that “fubar” text appear?

And is there really no local script editor/debug window like the documentation suggests?


#8

well in dev settings u can see the log imma guessing in there

o.o not a coder lol


#9

Thanks for your prompt replies, Judas.

I don’t even know what dev settings are … but I’m on a different machine now (my main desktop rather than the laptop in my kitchen) so when I log in I just get an empty world, no objects, with “NOT CONNECTED” in the title bar and a blue glow on the horizon.

Getting even more lost …


#10

The Settings menu should allow you to turn on the Advanced and Developer menus. In the developer menu are a couple of Script Log items that are what you want for seeing your script output.

When you’re on your desktop, do you run the sandbox there? I’d think you’d be able to GOTO localhost in that case?

I haven’t seen this fabled internal script editor. I thought maybe people using some other OS might have it but maybe it’s something more along the lines of bigfoot–fabled and elusive.


#11

Judas is right even if he doesn’t realize it yet, (we’ll make a scripter out of you eventually) the debug log output displays print statements, press CTRL/SHIFT/L or under the Developer menu select “Log” as Cinnabar suggested.

It is a pain to work with because it does not retain “on top” status and will disappear as soon as you click on the screen to do something, this makes it impossible to watch the log roll as you perform tests unless you have 2 screens or shrink the interface which is a pita, you must do the test and then show the log, and hope that all the constant spam hasn’t washed your print debug away.
This log will display output from Entity scripts and Client scripts, but for assignment scripts and server scripts you will find another log “View Log” on the Sandbox menu.
And yes the built-in script editor has gone away and there are tutorials which are out of date.


#12

Many thanks, everyone - now I get it! I can now see the output from my scripts at last.

I think the reason I couldn’t use HF on my desktop yesterday was because the sandbox wasn’t running - it all seems fine now.


#13

I don’t see how this problem has been fixed. Me too cannot see the script editor under edit menu. And this greatly makes the tutorials on scripting obsolete from the very beginning. Can somebody tell how to launch the script editor?


#14

Use your own text editor to script now (suggest Atom editor https://atom.io/) , all the scripts are stored locally on your disk and can be accessed through the file system. The script editor in hifi was borky and missing many features of modern coding IDE, not useful beyond the very basic examples.


#15

Yeah, thanks for the answer. I suspected that. :slightly_smiling_face: is there a documentation on where exactly the scripts are held in the disk, and maybe some scripting tutorials ?