Heightfield map importer and split map tiles import problem


#1

WHat i like to see in the heightfield map importer is the option to set the coordinates where the heightfield need to be placed. Now i can only import 1 image. and the others are impossible. Tried it with insert but thats nopt working also the scale is wrong compared to the heightfield importer. With insert you only see a very tiny heightfield if your lucky.

Better would be if you can import large heightfield maps and High Fidelity is later only loading the parts from disk that it needs. so size doesnt matter after import.

This heightfield loader need some improvements to work good with split maps.
Also a heightfiedl X and Z positioner in the heightfield importer would fix the problem sofar is see, you can then just easy import every map and multiply the position by the map size. in my case 1024.


#2

It would be very very welcome and nice if High Fidelity disable the "Follow Mouse’ by default. now its default enabled and very annoying to discover that its moveing like crazy after you corrected the coordinates.

Also that whole option have no use, you always need to place heightfield maps by coordinates. Uless High Fidelity would finaly get support for spacenavigator, then it makes a bit more sense.

Anyway very weird things happen when you use insert.
Other note, insert is not working. on empty domain (no metavoxels). insert dsont save the terrain to disk on windows/ and why you use insert and not import. because difference in controls an dscale settings.


#3

Tried the Insert function again after importinmg first 1 part. there problems…

  1. insert is using different scale settings and position compared to the importer.

  2. insert is not saving the terrain correctly. You see sometimes the terrain in very small scale. for weird reason i have 2 of the same small ones now, both are to small and placed wrong.

  3. the move by mouse is useless. you can move it. but as soon you move you mouse to the checkbox to disable it the terrain is moving also.

  4. insert dont save the terrain or is saving it wrong and not using all parameters you changed.


#4

@Richardus and @OmegaHeron, there is an updategoing out on of Metavoxels https://github.com/highfidelity/hifi/commits/master?author=ey6es . This will probably cause an issue with you current uploads.


#5

@chris - Thanks for the heads up. I’m waiting for my skills to improve and implementation to stabilize before I do anything serious with them. Looking forward to replacing mesh terrain in Heron with them eventually though.


#6

Thanks @chris , better wait until the new version is available.

It looks like the old heightfield map is still in use when you try to insert another heightfield map or start over from scratch. With the result that you see alrteady some old heightfield appear before you have loaded one. Think in the javascript code the heightfield filename need to be deleted.