Help please! All entities missing from home domain and can't restore backup


#1

I’m new but have been spending a lot of time here. I’ve built up a lot of entities on my home domain. Today all if it is missing, I’m kind of freaking out. So many hours of work. I’m trying to restore from the automated backups but as a longtime Mac user the PC/Windows 10 file structure is foreign to me. Following the instructions I have navigated to Users-Jason-AppData-Roaming-HighFidelity but here I hit a wall. According to the documentation I’m supposed to see a “server backup” folder or file which I’m supposed to copy and paste back into the Parent Directory. But I don’t see a “server backup” file or folder. Instead I see the following:
assignment-client (folder)
domain-server (folder)
Interface (folder)
Server Console (folder)
domain-server.json (file)
Interface-.json (file)

If anyone will help me I will be extremely grateful. After all the hours I’ve spent learning HiFi and building in my sandbox, I’m having a bit of a panic attack that everything is gone and I can’t figure out how to get it back.

Thank you,

Jason


#2

High Fidelity, the space where you contain entities and which agents visit is called a Domain.

IIRC You should be able to find your (hourly, daily, weekly, monthly and yearly default) backups in

%APPDATA%\High Fidelity\domain-server\entities

and these should be named similarly to how they are configured in the server configs (models.#.backup.daily.#, models.#.backup.hourly.#, etc ) in the backup config on the server.

To restore, simply rename it as main file.

Your ATP uploaded entities should be searchable from

%APPDATA%\High Fidelity\domain-server\assets

Ill check the file source again once I get home.


#3

Thank you Menithal for this post. I found the list of backup files that and did as you suggested - I stopped the server, renamed one of the daily backup files (models.json.gz.backup.daily.1) to the main file (models.json.gz) and restarted the server - but still no entities on my Domain. I will continue trying other backups. If you have any other suggestions I would appreciate it.

Thank you very much…


#4

You should probably check the file sizes of the backups or check their content. If they have anything, they should be spawning it in. Otherwise are you sure you are fully connected to the domain and in the same position where there entities are (domains are huge. You can check the coordinates from the model files)


#5

The file sizes of all my backups are suspiciously small, all under 1mb. I’ve only been using entities from the HiFi Market like the basic buildings. I’ve been logging in and out and building/editing for the past week and every time I connect and everything spawns in just fine. I have bookmarked 2 locations within my domain and when navigating to both of them there is nothing around. I realize that the domain is huge and perhaps somehow I’m not at the proper coordinates, so I am trying your suggestion but not able yet to figure out where the coordinate information is on the model files. I’m looking in my Assignment-client folder–>assets–>files and I do see a huge list of files with very long names of seemingly random alpha numerics. My domain can be found, it’s called “campfire”.


#6

Yeah it will be relatively small, but as long as none are within 10kbs they all should have content in them. Open one up and check the coordinates and teleport to them via /X,y,z


#7

Still working on this fix. One of my backups has successfully loaded - thank you. This time I quit Sandbox before renaming the backup file rather than just stopping the server. This is an early version of my work so it’s incomplete. The loading content notification is still spinning. I will wait for a bit to see if the rest of the entities spawn in.

I tried to open a file from the Assets folder as you suggested, however I was unable to open the file. Windows 10 asked me for the file to use, I tried Interface, but it didn’t work.

I apologize for being so… noob. And I appreciate your help.

It appears this backup has stopped loading since the “loading content” . About 30% of my work is here. I’m going to try to reload some other backup files using the new technique of quitting rather than stopping Sandbox.

EDIT: AFTER 8 MINUTES THE REST OF MY ENTITIES SPAWNED IN - I’M BACK.

A RECAP OF MY ISSUE for those in the future having a similar problem:

  • visited home domain: all entities missing. Waited 15 minutes, nothing loaded.
  • spent +/- 2 hours doing all the ‘basic’ troubleshooting - restarting Interface, loggin in/out, restarting Sandbox.
  • mini meltdown. Shook it off. Deep breath.
  • more troubleshooting - read about domain backups, tried to follow documentation. Seems what is written in the docs does not line up with what I’m seeing in Windows 10 in terms of folder structure/files.
  • Appealed for help here. Menithal to the rescue. See thread above.
  • Quitting Sandbox rather than stopping was the way I was able to load a backup entity file.
  • All entities respawned. Breath a huge sigh of relief.

Questions still unknown to me:
Why did no entries appear? Was it a user issue - maybe I needed to just wait longer, something was “slow” to load? But the “loading content” info went away and did not reappear. And I must have tried 15-20 times before loading a backup.

Looking at my backup files (I’m using the default settings) it appears that the “halfhourly” backups are not actually saving every half hour - it’s somewhat random.

I realize most of the HiFi users right now are much more experienced with all of this, so I accept my noob status and all the difficulties that go with that. And I thank Menithal for taking the time to help.

Back to work…