Help testing your network


#1

Hi All,

We are trying to reproduce a network issue and would love your help. Has anyone seen a situation where you are logged into High Fidelity and you’re not connecting to your audio or avatar server? However, if you looked at them on the Domain server they are up?


I know there are probably other bug that you are seeing, however we are interested and trying to identify this one.

Chris


#2

I visited several domains, no problems. The visited two of my own domains and also no problems. My domains do not have ATP enabled, assuming that might be related.

[edit]
What failed was when I tried to go to demo (avatar and audio ping = -1). I’m not on the whitelist so it did not connect me there but interface app showed me as being there. Maybe that’s your problem? :slight_smile:


#3

@Balpien_Hammere thanks for testing. When you went to ‘demo’ you would of seen all AC’s reporting -1. Correct?

Chris


#4

I had what seemed to be that problem on my domain weeks ago but it seems to have gone away now. For me it was intermittent, the audio ping would go to -1 and the audio would disconnect, but then it would come back.

It only seemed to happen when there was more than one avatar there (or maybe just anyone but me). When it happened we all would see it and get disconnected at the same time. But like I said, it stopped happening weeks ago.


#5

I think everyone used to have that intermittent everything drops problem some weeks ago, but it got fixed. I have noticed that problem is back, though not nearly as severely as before.


#6

Yes, all four: avatar, asset, audio, entity pings -1 (as it should be)


#7

Unfortunately (Or fortunately) I have yet to have bumped into this issue on 3397.


#8

the main thing with this issue would be that Entity AC is still connected but Audio and Avatar is -1


#9

any clue or suspicions what might trigger this? I can try various things with my two domains.


#10

We are getting closer. Potentially a software firewall rule on the router.


#11

Is this your problem? BTW, I had to get to the cached page since stackoverflow removed this post: http://cc.bingj.com/cache.aspx?d=4860448448909983&mkt=en-US&setlang=en-US&w=Iznk9h6pgGuiRuW0rN5dSKbxbhYh2725

UDP hole punching fails to connect to peer This took many hours/days to discovery this but here it is...So I have a Stun server that is publicly reachable. The STUN server does exactly what it is suppose to do, for device A and B, A gives B its information and B gives A its information (i.e., it is exchanges each others public IP/Port). Good so far. I stop communicating with the STUN server and I begin to try to punch through each others firewall/router (i.e., I bind to the same port as I was when pinging the STUN server and I begin to send datagrams to the other client's public IP/Port). These punches/datagrams never arrive at the client. I created an android utility app where I can specify a local binding port and of course, a remote ip and port. Using the public ip and port that the STUN server obtained, I enter this into my utility app. I run this utility application immediately after I obtained the information from my STUN server. It fails. The nats i'm behind use a preservation allocation scheme. That is, the source port is the same as the public port (http://en.wikipedia.org/wiki/TCP_hole_punching). I then change the port to something else and it works immediately. If I wait "some time" later, the original port I was trying to test on with my utility app will work.
If all routers were configured this way, it would be an easy fix. Anyone have this problem and how did you get around this? Thanks asked Jul 7 '14 at 19:21

#12

This is strange

I was not connected but have seen many nodes of me

What dos this mean?


#13

Next login with 3276 - all is ok again.