Help with multi-part fbx and textures


#1

I’ll try and keep this short. First off, I have successfully imported a mesh with a material and texture before, but there were only one of each. With this new mesh, I have 7 parts, 4 materials, and four textures. Each part only has a single material and texture, but a few materials and textures are used on multiple parts. I also made sure each part has its own UV map and that everything (textures, mesh parts, materials) have unique names. The issue is: the materials and textures don’t export to fbx correctly. I am using blender with the hifi-tools addon, and if I export then re-import the fbx, the textures and materials don’t appear on the mesh. They are loaded in the mesh’s data, and I can select the UV and texture from the properties menu, but on import, they are not mapped to the mesh. Didn’t know if anyone had experience with using multiple parts, UVs, materials, and textures in one fbx; and could give me a pointer or two. I’ve scoured google and the hifi documentation, but everything that others have tried doesn’t seem to work.


#2

Missing textures is usually a sign of a quirk of Blender’s FBX exporter. In order for the exporter to find the textures they must be in the same directory as your blend file.

And yup, that sucks.


#3

I recently had a similar issue & a friend in HiFi helped sort out some of the confusion. If your textures, etc. are scattered around various locations (not the same dir as the blend file), then you’ll want to go to File -> External Data -> Make All Paths Absolute. That was enough to fix my own issue & I hope it helps. Beyond that,just make sure you’ve got your Export options set to Path Mode: Copy & click the toggle next to it to embed the data into the FBX. Best of luck! :smiley: