Help with Vive Audio and other stuff


#1

Hi. I see everyone using their Vive without seeming problems, and I always have so much trouble that I end up ditching the headset. I really want to be immersed, and using the tools for which HiFi is being created.

I have many problems, but chief among them is the inability to hear from my headset once I put on the Vive. This is a recent problem, as it did not occur until the last two updates.

I set up all the things I want: Mic on, Users.js open, etc. while in regular desktop mode, and then I log out, fire up the VIve, and re-enter HF. At this point, I can’t hear anything from my headset. When I back out, and look at the Audio Settings BOTH Headphones and VIve mic are checked off, but I cannot uncheck the VIve, and the only way to get the check to disappear is to reboot completely!

Then, if I set it up again, I lose sound again. @Menithal mentioned it was a setting in Steam, but I am not sure what that means.

In addition, once I get this fixed, I have other difficulties, especially the inability to access any of the controls on the screen while in the Vive. My laser points overshoots any of the controls, such as toggling the mic, or teleporting by touching the Users.js.

I feel as if I fell asleep during the VIve class.
Thanks for any advice you can offer.


#2

Heya, this is what I meant:

Steam Automatically switches your main audio device to be the one from the head set.

High Fidelity uses its own settings which are not the ones the OS uses ( I\ve complained about this multiple times, but fortunately you can do the switch of microphone within the world ). Specifically its not a Vive issue, but an usability thing

You can mitigate some of it by checking the audio settings from here>

Make sure that you have the Mirroring the audio to your main sound source, which High Fidelity uses,
Microphone though has to be adjusted in world, because again, High Fidelity doesnt use the OS audio settings which SteamVR sets when it is started.


#3

Saturday errands to run, and then I will try it. Thanks for the detailed response, @Menithal.