Hifi changes audio output. ignoring settings in interface


This really start to be very , very annoying !
Every time when i start high fidelity to quick check something.
It change the audio output of my other programs. Like the Seconddlife viewer or VLC. Steam is not running at that moment !

Why is high fidelity changing sound output on my windows system without permission or the correct settings ! High Fidelity need to stop changing my audio output.

And to make it worse, when you close interface.exe , the settings not get restored. at least i where forced to restart secondlife viewer. This bug start to get worse and worse with i would say every new beta.

How to block audio device changes ?

Or high Fidelity is ignoreing the widnows audio device settings. because when my audio disappeared that setting where still correct.

That’s strange i just test it again. and now audio keeps correct ! So absolute a bug. now to find why.

Windows 10 anniversary did not made things better to mabye. when i turn my second monitor on the output is sometimes reouted to that device to.

Beta Release 19

Um, if the settings are getting switched, then the root cause is SteamVR, not High Fidelity.

SteamVR starts even if Steam is off because of the OpenVR implementation in High Fidelity.

Best way to make sure that it doesnt start is disconnect the power on your Vive when not using it. After that steamVR should not automatically start.


Steam VR has a setting, under developer, to not start when another application starts. I even believe Richardus has it set like that.
It also has settings to change the audio devices on startup and shutdown.

All those settings work as they should. I do not think steam vr is the cause.


How can steamVR start. i disabled that functionality. also theres no new steam icons when interface is starting.

So, i would say steam is not stsrting. and is not the problem.

ADD: Mabye it’s something to do with this settings. i turned it off. so far it seems to go fine. I think it where turned off on old installation too.


High Fidelity is still stealing my default audio device when steamVR is not running with beta 19.