Hifi:// url protocol handler on Windows


#1

Hi all,

Starting with Windows build 1191, we’re adding the required registry entries for hifi:// URIs to be recognized and handled by interface.exe.

We are working on the assumption that the program was installed in the default location and never moved, but we know this is not going to be the case for some of you. We have on our queue adding more features to the installer such as custom installation directory, but until we get there, for those that have moved the program, you will need to edit the following registry entries:

HKEY_CLASSES_ROOT\hifi\DefaultIcon
HKEY_CLASSES_ROOT\hifi\shell\open\command

And change the path to interface.exe to match what you have in your system.

Let me know if you run into any issues.
L


#2

its not working for me. The default one thats installed is pointing to the c:
drive. The installer did not used the installation path to make the
link, and my high interface.exe is not installed on the C drive. When i
create a link to interface.exe manual its starting interface.exe but
still not working because the -url “%1” cannot be added.

Can it be changed, so the installer is using the destination folder information.from the installer for the path ?

Let me change the path manual for now so i can test it.


#3

I have just test it, it works…
But. its starting another interface.exe instance, instead of useing the existing one thats already open.


#4

@Richardus yeap this is something that needs to be fixed in the application code - should be fixed soon.


#5

@leo, the Interface now does launch in Windows when clicking a domain hifi://Vue style link on a web page.

But, all location style links do NOT pass though the x,y,z or the rotation though. The avatar stays exactly where it was on last logout. So all locations act as if you just clicked on the domain hifi://domain link.

I confirm that if the interface is running, a second copy is launched - and confusion can ensue - rather than the expected move of the avatar to the new location (or better perhaps the bringing up of the “go to location” dialogue prefilled in with the x,y,z/rotation details of the clicked link. [Note again that the blocking modality of that dialogue is NOT good]


#6

In Windows Interface 1197 the My Locations menu item now gives an error.
The location table fails to come up completely now.

We’re sorry, but something went wrong.
If you are the application owner check the logs for more information.

On the web, when logged in, the my domains, my tokens and my wallet all show, but the my locations tab also gives the same error

https://data.highfidelity.io/locations


#7

Same here, I also had this a few days ago when editing a location after adding an image.


#8

@thoys + @Ai_Austin fixed that link, you should be able to see locations again


#9

thanks @b , I can also edit locations that have a screenshot again :smile:


#10

Hi @Ai_Austin build 1200 should fix the issue of going to the correct location when clicking on a domain.


#11

It does indeed, works fine on Windows now @Chris and@b and My Locations now works again in the Interface too.