High Fidelity Asset Converter (Alpha Release)


#14

We want all base functions to work before public testing.


#15

TOO LATE…


#16

Take off every zig :open_mouth:


#17

Absolutely right, @DGMurdockIII, the software uses assimp to convert the variety of formats in to a common format before pushing it through Autodesk’s FBX SDK.

Update:
Audio and Texture support fully implemented, and now just the case of wiring all the 3D stuff together. (who knew it would be such a tedious task?)

I’m alloting as much time to this project as I possibly can, and hopefully can open it up to Alpha scrutiny in the next week after a few more creases are ironed out from the foundation code.


#18

Thank you, @chris! I’m hoping it proves to be useful for the community!


#19

Only in the IT business someone can say “assimp” and nobody laughs.


Cannot get Textures to import with models
#20

To quote AssImp’s feature page;

Just because of its name: Assimp renders your program sexier.

I wont hazard a guess to what I was googling to discover the library.


#21

@Micah — “sexy asses” right? You were googling “sexy asses?”


#23

@SterlingWright, My legal team have advised me to reply with ‘No Comment’.


#24

Reaching out to the subject matter experts when it comes to modelling and all the other 3D gubbins…

So, very simply, the converter now supports FBX… But before I can wrap up the code, do a few minor tweaks and give you all downloads, I have one issue to resolve…

Here’s Derren Ducky… He was a collada model that was (by using the converter) imported, and then exported as FBX with embedded binary textures.

Viewing the FBX in Autodesk’s FBX Viewer provides this;

However, importing in to High Fidelity yields this as a result;

The URL for the model is: http://www.indigofuzz.co.uk/hifi/asset/duck.fbx

Any help would be most appreciated :smile:


#25

My guess is It looks like it has lost its uv mapping, still has the texture but applying it to a flat plane.
This is the main issue with converting things like obj and dae, if you can nail that issue you have a winner.


#26

Does HiFi have a unique way of handling UV maps then I wonder?


#27

Not really, maybe the uv map isnt being exported with the model and texture


#28

It surely is, hence why the Autodesk Review shows the model perfectly… Time for more coffee


#29

Yes you are right, the uv map is exporting along with the fbx, can you hook a link to the texture please.


#30

Texture URL:
https://dl.dropboxusercontent.com/u/63813161/model/duckCM.tga

I’ve discovered the hiccup I believe~ For some reason, despite the texture being embedded within the FBX file, it is still looking for the original texture file…


#31

Yes thats what I found, also fwiw, I have never had any success using .tga I always convert to .png, but your tex is showing inworld so something is working.


#32

Ive noticed that if the UV map CAN be overriden depending on existing textures and UV active UV map:

All the textures will follow the texture that is predominant (probably last), regardless of the textures original setting. Forexample I had a base Mesh for Ground mesh. On it I had a texture following the UV coordinates (Bump and Specular), and another that was repeated over the UV maps. All of the textures followed repetition rate of latter one instead of being 1 to 1.

Need to do more experimentation on these however.


#33

I remapped the texture to my local file system and packed it with the fbx using Blender and brought it into hifi.

Why the mapping is wrong out of autodesk I am not sure.

And I am happy to see .tga working :slight_smile:


#34

Is that using the texture file externally? or embedded?

Here’s an updated fbx with a PNG embedded; http://www.indigofuzz.co.uk/hifi/asset/duck-pngembed.fbx
and texture file http://www.indigofuzz.co.uk/hifi/asset/duckCM.png

Edit: Just realised it wasn’t exporting binary data… That might be a reason why. Derp.