High Fidelity Blender Add-On / Plugin - Version 1.3 Released


#101

If you are making an avatar from an MMD, you can paste these blendshapes anywhere in your .fst file. It’ll give you blinking eyes and mouth animation when you speak. Adjust the values (such as =2) to increase or decrease the intensity of the effect.

bs = JawOpen = MouthOpen = 2
bs = EyeBlink_R = WinkRight = 1
bs = EyeBlink_L = Wink = 1
bs = EyeBlink_R = Wink = 1
bs = EyeBlink_L = WinkRight = 1


#102

Added the recording from the meeting to the top most post.

Also available here
Just a word of warning around 20 minutes my audio starts to ramp up thanks to skype thinking I was talking too quiet.


#103

Thank you for your advice Menithal. The problem was solved by modifying the orientation of the head bone.

I have found another problem. Everything looks ok in Blender and Windows Mixed Reality Viewer, but when I use the avatar in High Fidelity looks like this with the orange materials over nose and temples. Looks like a materials problem

Link to the MMD Model


#104

Where do I find the FlowApp?


#105

That looks like the blush is visible, which you should spot whenever trying to look at the avatar in material mode on blender. You can fix it by temporary removing it.

The flow app can be found at https://hifi-content.s3.amazonaws.com/luis/flowFiles/flow.js
You may also use my version that should work fine. Above was having issues earlier today,
https://s3.eu-west-2.amazonaws.com/norteclabs.com/HF/scripts/flow/flowApp.js

Will probably later on be on the marketplace


#106

It does not appear in material mode and not in a render also.


#107

I’ve dropped instructions on how to use the MakeHuman avatar generation extensions HERE for those who are interested in trying it out.


#108

Forgot to mention,

Release 1.0.4 was released on Monday which has latest stuff from @Roxie

  • Removed Subsurf modifiers
  • Eyeblink blendshape shape
  • Foot rotation issues fixed
  • Some Cleanup

@Meta_Starostin will checkout the issue with the avatar during this week, was on break last week


#109

I’m having a blast playing with this.
I have so far been able use the HiFi standard armature from a Blender file I downloaded some months ago, rerig teh MakeHuman to it, and bring it inworld more or less successfully (vertex weighting needs work in the hands, of course, and I’m still shaky on editing fst files).
Since that’s all a fair amount of work I am delighted to see the Blender plugin. :grinning:

I am confused by the HiFi armature for MakeHuman - it’s different than the standard HiFi armature - fewer bones in the hands, added bones for tongue, no eye bones. That’s different than the armature generated by the Blender HiFi tools, which has the hand and eye bones, and doesn’t have the tongue bones or eye socket bones. I can make one conform to the other, but I don’t think I have a handle on what the most efficient armature might be.

Anyway. I got the new HiFi MakeHuman into Blender OK, but when I clicked on the MakeHuman tab in the Blender HiFi tools, I got a traceback error with ended in “context is incorrect”. I tried using the fst export anyway, which also failed, and distorted the armature and the mesh as well.

Does anyone know what I’m doing wrong?


#110

Sounds like you might have an older version of the makehuman hifi skeleton. The current one removed the tongue bones, added the eye bones, etc.

I’d be interested in seeing the full traceback, if you can paste it in here.


#111

Where is the current version?
After I find it I’ll see if I can recreate the problem and copy the traceback.
Thank you!!


#112

The current skeleton is available here LeftEye, RightEye, etc. should be in there.


#113

Thank you! I managed to get the files into MH (I am not a programmer; I can follow directions but that’s about it. But I did finally figure out that I needed to copy into a text file and save to *.mhskel).
I got it exported out of MH and into Blender OK.
The eye bones still differ from the standard HiFi skeleton - instead of eye socket + eye, we now have LeftEye, orbicularis03.L, orbicularis04.L etc. There are still three bones per finger instead of the four in the standard skeleton.
But it’s closer! I am still not grasping what the most efficient skeleton should be, lol, and my boneyard is getting crowded… :slight_smile:
I’ll see if I can replicate the traceback tomorrow.
ty ty ty


#114

The orbicularis bones are for the eyelids. The blender script uses those to generate the blendshapes for left-blink and right-blink as MH doesn’t include those blendshapes. HiFi simply ignores them.

I’ll make a note to automatically delete them as part of blendshape generation for efficiency.

As far as 3 bones per finger vs 4, I’m investigating doing an automatic extrude to generate a tiny tip bone. I’ll also be doing that for the top-of-the-head bone so hats can be worn.


#115

Yeah, there is a blush layer that doesnt show up on blender material mode,

You will want to remove this (selecting the vertice that is infront of the face, then pressing ctrl + L to select all linked, it should get a similar area to above, then you can delete it), or Alternatively, in high fidelity you could try creating a script to hide the blush layer “facials_material”, but that is a more advanced topic that needs scripting knowledge

@Roxie Ill probably implement a fst export settings to have the blendshape configurations in the fst be default.


#116

AH OK, that’s clever, and not having to fuss with shape keys will be nice. So we don’t need those eye socket bones.

I’m looking at Avatar Standard Compendium - the fourth bones are below the proximals, but apparently not the metacarpals. I tried copying weights from the bones for that, and I can’t say it came out well, but I started from the bone positions that MH came up with. Not pretty, especially the part where I tried distorting the MH mesh to the straight and flat bone layout of the HiFi standard. But I think I need to futz with this some more before I can talk about the hands intelligently - I haven’t played enough with how the armature layout relates to touch controllers.


#117

Traceback (most recent call last):
File “C:\Users\xxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\hifi_tools\armature\panel.py”, line 241, in execute
convert_makehuman_avatar_hifi()
File “C:\Users\xxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\hifi_tools\utils\makehuman.py”, line 256, in convert_makehuman_avatar_hifi
convert_bones(obj)
File “C:\Users\xxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\hifi_tools\utils\makehuman.py”, line 132, in convert_bones
clean_up_bones(obj)
File “C:\Users\xxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\hifi_tools\utils\makehuman.py”, line 89, in clean_up_bones
bpy.ops.object.mode_set(mode=‘EDIT’)
File “F:\BLENDER\2.79\scripts\modules\bpy\ops.py”, line 189, in call
ret = op_call(self.idname_py(), None, kw)
RuntimeError: Operator bpy.ops.object.mode_set.poll() failed, context is incorrect

location: :-1


#118

Do you have the model selected and in object mode when pushing the ‘MakeHuman’ button?


#119

@roxie: You might want to just force it to object mode and select the object, check the mmd exporter for reference.
That way you make sure its mode independent: Refer to the MMD exporter


#120

Already figured it out while you were on a well deserved holiday.

I found by selecting the material and unchecking the transparency and there it was. Then in edit mode removed the “mask” as you described and let the addon’s MMD conversion do the rest.

The eyes are uncoordinated but I know how to fix that :slight_smile: