High Fidelity Blender Add-On / Plugin - Version 1.3 Released


(looking at the instructions at https://github.com/roxanneskelly/hifi-makehuman-skeleton) I selected the skeleton in object mode, then pushed the MakeHuman button. I should try selecting the models instead? I may have done that, I’ll repeat everything and see.


Sorry, I didn’t understand this - what do you mean by “force”, what should I be forcing, what is mode independent? Do you mean try exporting as though it were a MMD model instead of a MH model?


@Ada_Radius Apologies, that was meant to be dev note @ at @roxie


@Menithal I’ll make those changes. I also need to add some real error handling and a few bone tweaks. Might not be quickly though, as I’ve guests in town who happen to be staying in my office :neutral_face:


I noticed there was some issues with the official flow app,

you may use this instead for now until high fidelity fixes it


Aside from an upcomming tutorial video,
Going to be doing some updates later this week:

  • Adding some default blendshape mapping for most models, if they are missing the required blendshapes but have something in place
  • Subsurface support for avatars
  • Checking some reported issues with Makehuman, No fixes yet but just to get some better understanding oni suses
  • Scene Export / Import improvements


Released the Tutorial Video on the OP


Release of 1.1.0

this is a bit of a smaller update, alot of prepatory work regarding the blendshape and flow binding, but there was a bug fix that needed fixing so released a patch along with basic features for avatar scripts and animgraphs


  • Script field for absolute / relative avatar scripts
  • AnimGrap Json field for absolute / relative avatar animation overrides


  • Scene Export issue when scene had empties.


@menithal. I try to look if i can convert my Fuse avatar with your blender add-on so i can edit and fix problems.

But is the video still uptodate ?
It’s talking about mmd that does not exists.
I just installed the menithal bledner add-on (and then started to watch the video :slight_smile: )

So i proceed and see.

Add: already complete confused. because my avatar is not rigged. I try to import my fuse 1. avatar in the new fuse website and rig it from there. This avatar stuff really need to be simple. fuse 1.3 where good. but the stoppe dit. and fuse 1.5 the removed important things.


The first video where I narrate things is up-to-date. It’s mostly just mmd based tutorial.

Fuse avatars / mixamo avatars are still questionable as I don’t have example avatars to use as base line corrections


Aha. i do not use MMD. i only have a mixamo avatar. I rigged a new one todo with the online rigger. so i could remove the eylash at least. So no black anymore. But the shoulder look a bit high and level. it’s not complete nice.

I guess you refuse to use fuse ? :smirk:

I did see something about makehuman on github. that could be the other solution.

But how do you get makehuman correct in high fidelity ?


MakeHuman guide is available here https://github.com/roxanneskelly/hifi-makehuman-skeleton
as posted above

Once I have time will have to centralize the guides and double check mixamo/Fuze avatars. Mixamo converter should work to some degree already, unfortunately its not very polished because Its not a priority thing.

currently however I am working on other things


Ok. i wil try soemday the makehumnan one. it would be a beter choice anyway then fuse. But…



Thanks @Menithal and roxanneskelly. It did at least worked for me. after i steped over that frustrating cache in high fidelity. the really need to fix the cache issues, and not sue it at some places or add reload button.

Just test avatar, still need to look why soem textures are not loaded and the FBX file size is far above what i like (20MB) i not want to go above 10MB. Possible n eed to save textures from MH and add it in blender after resize it.


How did you export the avatar from Blender to Fbx/FST? Did you use the ‘fst export’ or did you do a ‘fbx export.’ If you did an fbx export, did you set the “PathMode” to “Copy” and check the ‘texture embed’ box?


FST export did not work. It seems not to save anything to disk. So i used the way i always use. Export as FBX with the High Fidelity preset i use for years, that settiung include pathmode and copy.

Then i convert it in high fidelity to fst. And then upload it to my webspace. If you do that a few times you hit the frustrating cache. :open_mouth:

Just did quick double check. the skin is also not present in blender. So i need to retest it again from MH and save the textures to.

I do it slow, because there are still frustrating things after so long time in the UI and cache. Already happy that it worked so far. Gives me at least option to make a new avatar at some point.

STranger problem is that the avatar is way to big in blender ! 183 meters high. :rofl: Need to test different export setting in MH

It where just the first try !


I think by default, MakeHuman exports in centimeters, but blender import by default assumes measurements in meters. I have to re-scale the models to 1%, and Apply/Scale after import.


I’ve fixed my instructions a bit to specify changing the ‘scale units’ to ‘meter’ when exporting from makehuman.


Did the fst export show any errors in the logs? If it is missing things that is? It should be gathering everything up


I just try to save the fst to disk. because i get the save export dialog. It generated this error dialog.


If i enable the ATP function and hope it saves to local disk. it generate errors.