High Fidelity Interface crashes when starting up


#1

When I start the interface then it comes up, but before I can type in my login it crashes.

The crash log:

http://pastebin.com/AnmbS6gw


#2

Mine is also crashing on startup, although the exception type is different:

http://pastebin.com/eL4E1WE9


#3

Mine is crashing, too. Here’s the report

Process: launchd [637]
Path: /Applications/interface.app/Contents/MacOS/interface
Identifier: io.highfidelity.Interface
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [137]

Date/Time: 2014-04-01 14:22:42.715 -0500
OS Version: Mac OS X 10.7.5 (11G63b)
Report Version: 9

Interval Since Last Report: 206424 sec
Crashes Since Last Report: 1
Per-App Crashes Since Last Report: 1
Anonymous UUID: ED2C0546-C178-4562-849B-48D748AAD8AE

Crashed Thread: Unknown

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
rax: 0x0000000000000055 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x0000000000000000
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x00007fff5fc01028 rfl: 0x0000000000010203 cr2: 0x00007fff5fc01028
Logical CPU: 0

Binary images description not available

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 1
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 3164
thread_create: 1
thread_set_state: 0

Model: iMac12,2, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 2.7 GHz, 4 GB, SMC 1.72f2
Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3230554638424353302D444A2D4620
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3230554638424353302D444A2D4620
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.67.5-P2P
Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: ST31000528AS, 1 TB
Serial ATA Device: HL-DT-STDVDRW GA32N
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 5
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 4
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3


#4

Do you have a tablet or logitech mouse plugged in? If so, Unplug and try again.


#5

I do use a Logitech wireless trackball. I’ll give this another try when I get home.


#6

Yeah I am getting a crash dump on two different Macs with a fresh download even after unplugging everything and turning BlueTooth off.

“It happens” as they say.


#7

I cannot unplug my magic trackpad so I turned blue tooth off, disconnected leap motion device, unplugged the space navigator.
I all makes no difference, the interface keeps crashing.


#8

On my main PC, running windows 8 it crashes upon startup as well. When I look at the event log, I see it is related to my graphics driver:

Faulting application name: interface.exe, version: 0.0.0.0, time stamp: 0x5338ad3b
Faulting module name: atioglxx.dll, version: 6.14.10.12618, time stamp: 0x52a23a81
Exception code: 0xc0000005
Fault offset: 0x00a5db0b
Faulting process id: 0x143c
Faulting application start time: 0x01cf4e1fce56e756
Faulting application path: C:\Users\kevin_000\Desktop\Debug\interface.exe
Faulting module path: C:\WINDOWS\SYSTEM32\atioglxx.dll
Report Id: 0f579b6a-ba13-11e3-bedf-08606e454fc2
Faulting package full name:
Faulting package-relative application ID:

On my other Windows Desktop, I am able to login however when I hit enter for the chat, it will not load the chat it hangs on Connecting to Xmpp…


#9

OSX 10.7.5 Crash on start up, maybe just to old.


#10

Trinity- Interface only works on 10.8 and 10.9. Please update your OS


#11

Today I saw a fast popup that there was an update before it craned.

Installed it, tried again … but still crashes.

http://pastebin.com/aib6BJdF


#12

Looks like I had to hook up a webcam to prevent it from crashing at startup ?


#13

I’m still crashing, FYI


#14

Build 325 is also crashing on startup (no chance to try login) for me on my MacBook Pro, which I’ve never run Interface on before. Will try it on my main system later.

Report follows:

http://pastebin.com/LEzfvav4


#15

And 330 similarly won’t launch on the MacBook Pro.

full report:

http://pastebin.com/V8FKEscP

The same thread (6 in my case) is crashing each time:

Thread 6 Crashed:
0   com.apple.framework.IOKit           0x00007fff9401e8e4 IOHIDManagerCopyDevices + 9
1   libsixense_x64.dylib                0x000000010f2d528d hid_enumerate + 77
2   libsixense_x64.dylib                0x000000010f2cf387 USBDetector::find_devices() + 79
3   libsixense_x64.dylib                0x000000010f2cf698 USBDetector::hotplug_func() + 84
4   libsixense_x64.dylib                0x000000010f2d64de thread_proxy + 158
5   libsystem_pthread.dylib             0x00007fff8914e899 _pthread_body + 138
6   libsystem_pthread.dylib             0x00007fff8914e72a _pthread_start + 137
7   libsystem_pthread.dylib             0x00007fff89152fc9 thread_start + 13

Incidentally, I notice that my main system is not requesting that I download any new versions (it’s on 321). Is this intentional?


#16

Interface 365: When I unplug my Wacom Intuos 5 touch tablet and also the Griffin Powermate I’m able to start

My 3Dconnexion SpaceExplorer causes no crash

Crashed Thread: 7
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010 …etc


#17

When I’m logged in with unplugged Wacom tablet: when hook it back again, no problems
I can use my tablet pen to select commands from the menu for example … no crash


#18

Updated update: I restarted and it works fine now >.<

Update: Got 395 installed and get the same “index 0 beyond bounds for empty array” error.

Original Post:Yesterday I loaded build 393 for Mac and it worked fine, but this morning I’m getting a crash as Interface tries to open. Here is a partial part of the report I am getting.

 Process:         interface [9271]
Path:            /Applications/interface.app/Contents/MacOS/interface
Identifier:      io.highfidelity.Interface
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [239]
Responsible:     interface [9271]
User ID:         502

Date/Time:       2014-04-21 17:44:40.565 -0500
OS Version:      Mac OS X 10.9.2 (13C64)
Report Version:  11
Anonymous UUID:  76B68A1A-EAF6-239D-6227-BABEAEEB57F0

Sleep/Wake UUID: D3348088-7539-45B1-90CA-1FF8D3A17ED3

Crashed Thread:  31

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception 'NSRangeException', reason: '*** -[__NSArrayM objectAtIndex:]: index 0 beyond bounds for empty array'
terminating with uncaught exception of type NSException
abort() called



Bluetooth: Version 4.2.3f10 13477, 3 services, 23 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM256E, 251 GB
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: Hub
USB Device: Internal Memory Card Reader
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Air, Apple Inc., 23.4

#19

Well I broke my hf, made it crash every time it opened, here’s how lol
I was working on a body for my avatar running from my own server. Something must have been wrong with it every time I logged in it would look at my broken file on my server and poof.
I took a while to suss out this was the problem and removed the fst from my server and I’m back in HF.
What Hf doesn’t have that I think it could use it a load default settings option. I.E make me have to log in again and default everything back to the way a new install would be.
Uninstalling Hf doesn’t do this unless I’m doing it wrong.
I dragged the app to the bin, I also removed Library-appsupport-high fidelity
and removed library-Caches-io.highfidelity.interface.
none of these things removed what ever it is that made Hf continue to try to load my borked ava then crash.
As I mentioned deleting the file from my server sorted it so I’M back in


#20

To expand upon what @Judas said, if you keep crashing upon startup and you reinstalled the latest build, also try removing any running scripts from your hard drive that might be anchored in upon startup. In other words, lets say I’m working on a kevin.js script and I loaded it from my Desktop and now I can’t get into the application anymore because it crashes upon startup. Try moving the kevin.js on the Desktop to another folder, it will then allow the app to load as it does not try to pull that file in.

A bit of a work around but it should work.