High Fidelity Meetup for Friday 2pm PDT


#1

Hi All,

Agenda for tomorrow.
-Go over the Avatar recording functionality. The latest release of Interface has recording implemented. If you want to try you just need to run Recorder.js. Forum post is here: https://alphas.highfidelity.io/t/recording-and-playback/822/21

  • Update on our entity refactoring work
  • Update on The City with AI project.
  • Show and tell from Alpha users (Email me if you want to show something)
  • Q&A.

#2

@Chris, can you ask at the meeting if anyone else is having problems on Windows since build 976. I have not been able to update to any version after 975 when moving to 976 (which seemed to be about audio changes) and five or six versions I have tried since then right up to 1009.

Can the devs suggest a way to clear the “app crash” that occurs in build 976 onwards. The system on which it crashes has the Oculus 0.4.1 SDK and runtime installed, but I even uninstalled that completely and it still crashed… though that does not mean all changes made to the system by the Oculus code was removed I supposed.

Be (stuck on 975)


#3

@Be_Austin Running right now 1009 on windows 7 64bit without problems. Did you checked if all your drivers are uptodate and all (optional) windows updates are checked and where needed installed ? microsoft also gives sometimes hardware drivers.


#4

I am also running the latest versions on an almost identical Windows 7 system too. And all up to date with Windows Update. Only difference is that the machine that does an “APPCRASH” every time from build 976 onwards has the Oculus Rift Runtime 0.4.1 on it. And it still app crashes even if that is uninstalled and rebooted afresh.

So build 976 is causing some problem or other and once the problem is there is not being cleared by fresh installs… So I am a bit stuck. It must be audio related as all the changes in 976 were for audio matters.

I would appreciate advice from the HiFi dev team on a way to “unstick” this crash problem or this particular desktop (unfortunately and my DK2 testing) is scuppered.


#5

Just some diea. did you checked if tehre’s not still some driver installed from the oculus dev kit ? it soun ds like for me something is still hanging around. did you uninstalled interface.exe compleet and reinstall (including ini) ? otherwise its dev turn.


#6

Hi @Be_Austin we are on Windows 7 in the office using a rift and have not had any problems. Can you show your log files?


#7

Running on Windows 8.1, and I have not had any problems.


#8

@Richardus, I just tried again. Completely uninstalled Interface and Oculus Runtime. Deleted the user app data folders in <Local and Roaming for both. Rebooted. twice.

Install win 1014 (latest) and it app crashes.

Installed 976 and it app crashes

Installed 975 and it works fine again.

No Oculus runtime on he system at all during the tests, though

See my other thread for the console logs which I hope help. @Chris, can you be clear which log you want and from where… and should I put it in a post here or send it to you by e-mail?

Note I too have a Windows 7 and 8.1 system that has never had an Oculus Rift near it working fine with 1014 too.


#9

@Chris, I looked at the log for a crash of 976 and nothing unusual is in there. its not logging what is causing the crash… this is one run, though some logs of it crashing are much shorter… and it does not get that far… often ending at the line where its says…

[2014-08-22T17:01:44] Unable to set up audio input because of a problem with input format.

Anyway here is one of the longer logs from a crashing 976 build… ending at a QT application creation…

[2014-08-22T17:06:56] First call to Menu::getInstance() - initing menu.
[2014-08-22T17:06:57] QFileSystemWatcher::addPath: path is empty
[2014-08-22T17:06:57] NodeList socket is listening on 51271
[2014-08-22T17:06:57] Changed socket send buffer size from 8192 to 1048576 bytes
[2014-08-22T17:06:57] URL for node authentication has been changed to https://data.highfidelity.io
[2014-08-22T17:06:57] Re-setting authentication flow.
[2014-08-22T17:06:57] DEBUG [ “NONE” ] [ “” ]
[2014-08-22T17:06:57] Found a data-server access token for https://data.highfidelity.io
[2014-08-22T17:06:57] The default audio input device is “”
[2014-08-22T17:06:57] Logging activity “launch”
[2014-08-22T17:06:57] output device: “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] “Speakers (Realtek High Definiti” “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] “Realtek Digital Output (Realtek” “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] DEBUG [ “Speakers (Realtek High Definiti” ] [ “Speakers (Realtek High Definiti” ]
[2014-08-22T17:06:57] “Speakers (Realtek High Definiti” “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] “Realtek Digital Output (Realtek” “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] The default audio output device is “Speakers (Realtek High Definiti”
[2014-08-22T17:06:57] The audio output device “Speakers (Realtek High Definiti” is available.
[2014-08-22T17:06:57] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-08-22T17:06:57] The desired audio format is not supported by this device
[2014-08-22T17:06:57] The format to be used for audio output is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-08-22T17:06:57] Ring Buffer capacity in frames: 3
[2014-08-22T17:06:57] Unable to set up audio input because of a problem with input format.
[2014-08-22T17:06:57] Created Display Window.
[2014-08-22T17:06:57] Status: Using GLEW 1.10.0

[2014-08-22T17:06:57] Initialized Display.
[2014-08-22T17:06:58] QFileSystemWatcher::removePath: path is empty
[2014-08-22T17:06:58] QFileSystemWatcher::addPath: path is empty
[2014-08-22T17:06:58] Changing face model for avatar to “http://vue.ed.ac.uk/hifi/avatars/angie_head_mixamo.fst
[2014-08-22T17:06:58] Changing skeleton model for avatar to “http://vue.ed.ac.uk/hifi/avatars/angie_standing.fst
[2014-08-22T17:06:58] Changing display name for avatar to “Be”
[2014-08-22T17:06:58] Application title set to: (build 976)
[2014-08-22T17:06:58] Looking up DS hostname hifi.aiai.ed.ac.uk.
[2014-08-22T17:06:58] Logging activity “changed_domain”
[2014-08-22T17:06:58] DS at hifi.aiai.ed.ac.uk is at 129.215.219.148
[2014-08-22T17:06:58] Application title set to: hifi.aiai.ed.ac.uk (build 976)
[2014-08-22T17:06:58] Clearing the NodeList. Deleting all nodes in list.
[2014-08-22T17:06:58] ModelTreeRenderer::clearModelsCache()…
[2014-08-22T17:06:58] Loaded settings
[2014-08-22T17:06:58] Faceshift: Connecting…
[2014-08-22T17:06:58] Sending intial stun request to 54.215.251.124
[2014-08-22T17:06:58] init() complete.
[2014-08-22T17:06:58] recreateVoxelGeometryInView()…
[2014-08-22T17:06:58] Voxel parsing thread created.
[2014-08-22T17:06:58] Startup time: 1.83 seconds.
[2014-08-22T17:06:58] New public socket received from STUN server is 129.215.219.52:51271
[2014-08-22T17:06:58] Total time to generate stars: 15.5424 msec
[2014-08-22T17:06:58] Total time to retile and generate stars: 37.472 msec
[2014-08-22T17:06:58] Downloading script at QUrl( “http://public.highfidelity.io/scripts/defaultScripts.js” )
[2014-08-22T17:06:58] Username changed to “Be_Austin”
[2014-08-22T17:06:58] Application title set to: Be_Austin @ hifi.aiai.ed.ac.uk (build 976)
[2014-08-22T17:06:58] Image with alpha channel is completely opaque: QUrl( “http://vue.ed.ac.uk/hifi/avatars/angie/AngieTexture.png” )
[2014-08-22T17:06:58] Image with alpha channel is completely opaque: QUrl( “http://vue.ed.ac.uk/hifi/avatars/angie/AngieTexture.png” )
[2014-08-22T17:06:58] Image greater than maximum size: QUrl( “http://vue.ed.ac.uk/hifi/avatars/angie/girl_body_diff.jpg” ) 2048 2048
[2014-08-22T17:06:59] Logging activity “loaded_script”
[2014-08-22T17:06:59] QSystemTrayIcon::setVisible: No Icon set
[2014-08-22T17:06:59] Downloading included script at “lookWithTouch.js”
[2014-08-22T17:06:59] Created QT Application.


#10

Hangout for the meeting: https://plus.google.com/hangouts/_/hoaevent/AP36tYftr_yrKpPU_bnO8HTsIasWwPwK6ElSa9C6SraDKCqRzLu3Gg?authuser=0&hl=en


#11

I keep running for now my dualcore server. High Fidelity need to run fine as server on dual core amd x2 3.0 ghz low per cpu. windows. expect that high fidelity must run betetr at some point. not sure why audio ping where so extreme high. maby the traffic shaping on that network segment ? but with less avatars it possible works fine. maby its possible to try at soem point with a few. or some other can try it. and let me know. cpu where pretty at the max. maby system where a bit mixed up to.


#12

Here is the video from the meetup:


#13

@Chris thanks for asking during the meetup if anyone else was having the win 7/audio/DK2 environment issue.