High Fidelity Server Console


#1

We just deployed the Server Console. This means the Stack Manager is now officially decommissioned (RIP).

You can download the latest client and server from the download page.

The Server Console will tell you how to use it when you run it for the first time.

Migrating from the Stack Manager

If the Server Console detects that you have Stack Manager content on your machine it will give you an option in the tray menu to migrate that content.


#2

@b on this push it seems stack was left referring to path_to/.config/High Fidelity - dev/ vs correct path_to/.config/High Fidelity/

Seen on linux build from this push.


#3

Thanks @OmegaHeron.

In case anybody else who is compiling assignment-clients and domain-server hits this issue I’ve replied here - https://alphas.highfidelity.io/t/last-pushed-build-of-stack-is-referencing-config-for-pr-build/10087/5


#4

Just updated on windows and it didn’t migrate my builds.so im looking at an empty domain
i did choose migrate

my old model file was models.json
the one it created if i’m looking in the correct place is models.json.gz
c-users -judas appdata roaming highfidelity-assignmentclient-entities

it got the placenames and connected and is running

what did I do wrong?


#5

@Judas

Sorry about that - we didn’t handle migration of non-compressed models files.

Can you do the following:

(1) Stop your server

(2) Copy

C:\Users\Judas\AppData\Local\High Fidelity\Stack Manager\resources\models.json

to

C:\Users\Judas\AppData\Roaming\High Fidelity\assignment-client\entities\models.json

(3) Restart your server

Then the Server Console assignment-client should pick up your non-compressed entities file.


#6

Installed the console thing on Windows 10 and migrated my stack manager stuff.
I just want to say I did not run into any problems. Maybe i’m lucky :slight_smile:


#7

Intressting, not needed to migrate anything. possible because i where already using the new format. Except the first time a installation on wrong location. that i need to delete manual after restart. it seems to work fine.


#8

I am going to start from scratch anyway. I have too many entity issues in what I have in my domains, so a clean slate start seems appropriate. Besides, this gives me a chance to review the new-to-HF install process.

[edit]
I uninstalled interface, stack manager, and thevs2013 re-dist packages. Launch the new HF package, very clean, nice.

Here is the advice on chat


#9

I saw the message that it was going to set up my domain with a default scene, also saw the download happen. Butm when I entered the domain it was devoid of everything. I’m digging around to see what went awry in that first install.


#10

Hi @Balpien_Hammere in the console go to “Go Home” it will take you the content you just added


#11

Did that, waited 5 minutes, got this:


#12

The downloaded stuff is there, now checking if the settings were not updated.


#13

OK, the installer did not change the location of the models. That’s understandable.

So, I set it to C:\Users\ReneVega\AppData\Roaming\High Fidelity\assignment-client\entities\models.json.gz
(also tried /… variant, no go)

…restart the server, and… nothing.

Felling lonely, I edited a cube I made, moving it around was very spastic. Disappointing. Am done for a while. Will check back in February.


#14

I get this when I try to update the new server console:

and seems to happen when I close Console too…

Edited to add: My mistake, I didn’t realize that “Server Console” meant domain. After stopping server via nice new tiny icon I can update. One thing though… it is kind of a pain to have to shut down domain to update Interface client. Maybe the updates should be separated? I mean … if one needs updating, not have to update both?


#15

Some miscellaneous comments:

  • The contrast in the Hello Worlds!" screen is pretty poor: text looks washed out, making it harder than necessary to read.
  • The font size in the Domain Server and Assignment Clients log window is way too large. (Windows 8.1).

#16

Tried the above instruction
nada

ok i fixed it
the console gave itself the wrong location to look for its models file once i changed it to models.json.gz
it worked

so guesses the console migrated the settings loaded in the wrong location ?


#18

At this point it would be good if high fidelity always advise the uninstall the stack-manager before installing the console.

The contrast in the download window is terrible. Why do peoplem get always the ideas to put light grey text on white background ? Not really readable what the progress bar is saying.

Anyway, migration worked now i use the right version :open_mouth:


#19

There is no such relative folder in the Ubuntu file structure.

I have ~/hifi/build/assignment-client/resources however there is no entities folder.

Is there a respective folder I can move my models.JSON.gz file into to make this work?


#20

On Ubuntu your models file should be at

~/.local/share/High Fidelity/assignment-client/entities/models.json.gz

It would be helpful to have log from your entity server to confirm that’s where it’s looking and understand why it hasn’t properly migrated that file for you.


#21

@b I like it now its working btw , love that it runs just in the tray now cool new icon all polished lookin.
I would imagine new users wont have all this moving stuff around stuff to deal with.