How do I create my first voxel?


#1

This may sound silly, but I’m not able to place an initial voxel anywhere. I can happily add on to someone else’s existing creation, but I can’t go out to the middle of nowhere and “seed” a new creation. I feel like I’m missing something obvious…?


#2

Hey @brian,

You can hit the 9 key to spawn a voxel in front of you.


#3

Thanks @Atlante45. Is there a list of all the keyboard commands? I didn’t see it in github.


#4

No, but there are some indications in the scripts headers usually. If you built from the source, you can find those scripts in examples. The one you’re looking for is called editVoxels.js


#5

Interface 393 on Mac

With the Metavoxel Editor I can’t build

Tried on my home lot
And tried on all 3 grid planes

“Hit the 9 key to spawn a voxel in front of you” = nothing happens

I can “create” a voxel: but after I release the mouse it disappears
Also the case when I try to color something: I can paint, but after releasing the mouse it disappears

Am I missing something very simple ?


#6

Hi @Robertus try logging into localhost, command D on the mac, Then copy this data below and save it as test.js to your hard drive. Then click FILE then OPEN AND RUN SCRIPT FILE and then to make sure you are at the location where the script makes a voxel, type COMMAND, SHIFT L and enter coordinates 0, 200, 0.

DOWNLOAD

If you don’t see the voxel, click COMMAND , (comma) and then turn max voxels up to 550,000 and click Save All Changes.

The result is a red voxel at that coordinate size 1 meter. You can change the colors by changing the last 3 parameters in the setVoxel function (255, 0, 0) means Red = 255, Green = 0, Blue = 0.

Hope this helps.


#7

@Kevin Hi and thanks for this nice guide
On local.host= ok and now also on domain alphas created: my first red voxel … tada :smile: )

On var x = 6042;
var y = 202;
var z = 6402;


#8

@Robertus congrats that is great! Isn’t it a great feeling seeing that first creation!

If you want to take the next step, I have a nice tutorial to make a house. Here is the link if you like. I am always here to help. Never give up and always keep positive!

CLICK HERE


#9

Tried one of your scripts because i dont see or cant build any voxel.
adjusted the coordinates to the location my avatar where inworld.
But still dont see any voxel. Its windows system with git compiled source.
tried it in root , and on local server. no voxels.

The invisible voxels started for me around 3 weeks ago.


#10

Hey @Richardus_Rayma I am not sure as I am running on a Mac. I am not sure if there is a stable windows build at the moment you can try reaching out to @thoys.


#11

Just compiled the latest version from git, and the voxel world appears again how i know it…


#12

Three weeks of trying, and all I have is this voxel.

The voxel’s name is Wilson.

Wilson says I should get out more.


#13

Hi @EllieBrewster

I am currently working on a residential home model I call The Genesis to which I am going to create a JS script where you can pick the color of the walls, exterior and interior and place various objects throughout the model on your plot.

It will include detailed descriptions of the algorithms so that you can see how to modify the script or take sections and make some of your own creations. I hope to have this done late next week.

In the meantime, there is a section in the forum here called “Fun and useful JS scripts” click here.

Feel free to mess around with some. You can start by using the setplotarea to create voxels to detail your land boundaries. It’s a great start to voxel creation.


#14

Hi @EllieBrewster it looks like you are not connected to a server (see top left of Interface. “Servers: 0”). Can you try and go to the sandbox, see image below for instructions:

If you connect correctly you should see sandbox.highfidelity.io at the top of your interface client.

Also I can not see the voxel editor on your screen. click the ‘tab’ key to bring it up.


#15

Thanks, Kevin, you’re a brick.

Unfortunately, I still have to figure out why I can’t run scripts.

Once I figure that, I’m on my way. All I want is a floor I won’t sink into.


#16

Thanks for getting back to me so quickly, and for being so patient.

Here is a picture of me and Wilson, on the root.highfidelity grid… The strip can be seen in the distance. Running OS 10.9.2

As you can see, I am more intimately connected to Wilson than I really care to be, even though I’ve turned on all collisions, but I’m sure I can work this problem out later . Wilson is also lower than I remember placing him, but that’s probably also a small problem.

Here are the problems that remain:

TAB KEY DOES NOT BRING UP VOXEL EDITOR.
I have fooled around quite a lot with the options, but I can’t see where I could have turned this function off. I have tried command/tab, option/tab and all manner of combinations.

I have set up a server with MAmp, and I have a couple of Kevin’s scripts stored there. (That’s how I created Wilson). However, the other scripts don’t work, and trying to erase everything causes a crash.

OPEN AND RUN SCRIPT FILE
from HTDOCS in MAmp directory - nothing happens with the rez floor script

TURN OFF ALL SCRIPTS CAUSES CRASH
Crashed Thread: 0 Dispatch queue: com.apple.main-thread
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000000000bf

I tried this in the sandbox as well - I now have four running scripts and can’t seem to undo them. I think I will stop now, before I cause some damage. Thanks for your help, I usually do pretty well figuring this stuff out for myself, as soon as I get my feet on the ground.


#17

Hi @EllieBrewster I am not certain why on the MAC you are not able to run certain scripts. Here is what I would try:
1)Create a new folder on your desktop called Scripts.
2)Move all of your HF scripts to that folder.
3)Re-Run from that new directory.

This might help as I know there was a bug with caching old scripts. If this does not work, I would reach out to @chris and perhaps try to re-download the latest MAC version @ https://highfidelity.io/download/mac .


#18

I’m on Windows, but Tab doesn’t bring the voxel editor either.
Nor does clicking 9 or 0 create a voxel.


#19

ok if you cant see the build tools its possible they didnt load (HF quirk)
what you need to do is load the script from the public scripts. Easier said than done.
open this link
http://highfidelity-public.s3-us-west-1.amazonaws.com/scripts/defaultScripts.js
then cut paste the link into file-open and run script from url

then the build tools should appear and then 0 will work


#20

That did the trick, thank you!