How to get better color in your mesh?


#1

It’s still something i get stuck on, the colors look a bit flat and dull. not bright and colorfull.
And i still cannot figure out wich slider in blender is doing that.

How to make a color look not like it have sit 10 years in the sun ?

ADD:
|Mabye not the right option. but emit in shading brings at least something back.


#2

I think alot of how colour responds in hifi is to do with the sky box and lighting.

I was messing with the light entities well i was playing with the firefly.js script
and the one that makes the flying boat thing

They are using the lights differently to me
I was setting my intensity to say 2000 and making it big
they are having an intensity of 50 and making the fall off bigger
its prob 2 ways of doing the same thing but I feel its about experimentation guess work and luck. I find the default lights horrible washed out and plastic looking.

I recommend deleting everything that makes light the sky boxes and everything
then add in lights one at a time and messing with them and seeing how they work. note down the effects
then teach me :smiley:


#3

I noticed that sometimes my meshes were coming in in less-bright than expected. I found a slider in my material settings that was in the mid range which affected how bright the model was. I’m not sure what software you use but it may be worth a shot to see if your material has a similar property. I do agree with Judas as well. Getting your lighting set up right is important too. It can dramatically change how a mesh looks.


#4

If you are using Blender, you are noticing a problem I have had forever until just a few months ago, Imma tell you a secret.

In Blender, the materials panel, the first 2 options are Diffuse color and Diffuse intensity.

By default the color is less than pure white and the intensity is 0.800

On every single item you make, where there is a texture, you should push the color slider to max, its only a little bit but that little bit takes 10% of your brightness away.
Next you should drag the color intensity all the way up. By default its at 0.8 so it it taking 20% of your texture intensity away.

The result is 30% brighter, more intense colors and a fresh lemon fragrance.

Also Specular color above about half way will result in some surface shine which dulls the graphic quality of the texture.

The bad news is you have to do this for every single texture on every single object.

Remember how all the houses and trees on domain earth were dull and washed out until a couple of months ago? Now they are clear and bright, thats what I did.


#5

Here is a pictorial of the above.


#6

Here a small tip to fix the default sliders to max every time you start blender.
Create a new file, create a new material and put the default settings that you want for blender to start with every time to open the software. Go to file > Save startup file.


#7

Thats cool, save a bit of time. But it only works for the first material, is there any way of setting a preset material that I can just call up every time I start a new material? That would save heaps of time.


#8

Yes, you can create multiple materials, set the default parameters and do the same (save startup file). Another way to save material presets / libraries is to have a master blender file with a bunch of material setups. That way every time you want to call a specific material you just go to File > Append > Material and wuala. Blender is developing an asset management and there are a lot of ways to have preset libraries in your scene with addons like this: https://cgcookiemarkets.com/all-products/asset-management/