How to get full body tracking working for Oculus and other headsets


#1

To start off, you should force OpenVR/SteamVR on with a System variable. You do that by

  1. In Search, search for and then select: System (Control Panel)
  2. Click the Advanced system settings link.
  3. Click Environment Variables.
  4. In the System Variables section, your’re going to want to hit the New button, and then paste this: HIFI_DEBUG_OPENVR and make sure the value is set to 1.
    It should look like this: https://images-ext-2.discordapp.net/external/9c55XzzbdkxVNuys3AEc0-zQNr5YBh3vOVLdtr8GmPw/https/cdn.discordapp.com/attachments/489924960668614689/489925050783236097/unknown.png?width=616&height=677
  5. Press OK and restart your computer.

Now it’s time to load a couple of scripts in High Fidelity which will fix a couple of problems:

  1. If you have an Oculus, this will fix controller bindings in SteamVR as they by default are setup to for Vive controller: https://cdn.discordapp.com/attachments/539565851356168203/542217379673931797/oculuscontrollerfix.js
  2. To calibrate your Vive trackers correctly, you’ll need this script: Second is important for all users because by default the Vive tracker will not calibrate with out it
    https://cdn.discordapp.com/attachments/450921887925796865/533020880100392969/viveMotionCapture_2.js To calibrate with it, stand in a T-pose then hold trigger and grip
    buttons on both controllers for a few secs. if you do that again it’ll set you back to normal, like a toggle. Note: You will not be able to use the regular calibration
    at this time. This has only been tested with hips and feet, though chest should work and maybe more.

Credit:
Thoys for writing the oculus controller scirpt and telling me about the system verable
Monoglu for finding and modding the vive Motion Capture scirpt.
Caitlyn for helping with guide formatting

Ps hopefully they will fix calibration to work with none vive setups.


Can I use Oculus HMD and Vive trackers at the same time?
#2

Pro tip: You can also just use this batch file to run Interface without needing to edit system variables.

@echo off
set HIFI_DEBUG_OPENVR=1
interface.exe

Just copy and paste that into notepad and name the file “debug_openvr.bat” or whatever you want (as long as it ends with .bat). That should raise the flag it’s looking for without having to tinker with system settings.


#3

Also for me, using WMR I did not use debug mode at all. I had to enable the ‘use multiple drivers’ variable to get it to load both, from there it was all HiFi.