How to increase audio injector maximum?


#1

Hello,

I’ve written a script which plays a lot of audio samples. It works fine on my home sandbox, but when I deploy to a digital ocean server I get an error saying that the maximum audio injector has been reached (see below). I guess this is a server setting somewhere to increase it, or is it driven by the RAM of the server?

[08/24 19:13:34] [DEBUG] [hifi.audio] [27093] [entity-script-server] AudioInjectorManager::threadInjector could not thread AudioInjector - at max of 40 current audio injectors.

[08/24 19:13:34] [WARNING] [default] [27093] [entity-script-server] AudioInjector::playSound failed to thread pitch-shifted injector

thanks for you help!

Antony