How to load and run scripts correctly?


#1

I opened the running scripts window, which says that “there are no scripts currently running”.
So I decided to open and run script from URL with http://highfidelity-public.s3-us-west-1.amazonaws.com/scripts/defaultScripts.js
There’s still no scripts loaded or running, maybe it’s not the right way or I am wrong somewhere to load a script from URL or it can be due to my network ?
Because I have no issues loading a script file from my computer and the scripts appear and run perfectly.

Please can you tell me how to load and run scripts from URL correctly?


#2

Yes, this is the correct way to load a script from a URL.
Which is weird since you have the correct address and that it’s not really big files.
If you can run with at reasonable framerate, you should be able to load those scripts.

Do you see anything in the log when you try to load it ? (CMD + L to open the log)


#3

Sorry for the late feedback, I today tried again to load scripts from URL, it worked fine and immediately, with any scripts including those which does not loaded before.

To answer this question I must access the logs of my last week session once I don’t anymore experience this issue.


#5

Is there easy way to download all scripts to Harddisk ? so it yu can study them ?


#6

I believe on Windows they are already downloaded. If not, you could download the entire source code https://github.com/highfidelity/hifi which will include the example folder OR they are also here: http://public.highfidelity.io/scripts


#7

Thanks chris, i see its in the git i have downbloaded. i go download a newer update.