How To Really Really Completely Uninstall Interface From Mac


#1

This has been a rough week for Mac Interface. Maybe not in and of itself, but perhaps on this specific Mac Mini, with the specific version leaps that I’ve made of late.

For one example, I was getting working audio, but couldn’t see anything, though I could still see the list of users at the lower-left corner, could click on “Thoys@Music” and I would show up there, and audio still worked both ways. So I could explain to Thoys and Kevin the problem I was having, and Thoys talked me through deleting…
(user_dir)/Library/Application Support/High Fidelity/Interface/data8
…and bingo, stuff worked again.

That lasted only for the remainder of that one evening. Next day, I was on my KelvinD domain, and all I see is white glow. No list of users. The Esc key doesn’t go to lobby. Typing a different domain name in the address bar does nothing. Reloading Default Scripts - nothing. Stuck.

So - used CleanMyMac2 to “completely uninstall” Interface.

Why does the data8 folder persist? Dunno.

Took matters into my own hands, and deleted entire High Fidelity folder.

Then, re-installed Interface.

Then, launched Interface.

Boom. I’m at KelvinD. Questions:

  1. How does it know that “KelvinD” domain even exists?
  2. How does it know my login credentials?
  3. How did it save my horribly borked misconfiguration?

So I need some advice on how to completely wipe High Fidelity stuff from this Mac’s long term memory. I don’t want to reformat and then Time Machine Restore back to a week before I ever heard of you guys. That would be brutal.


#2

So here’s the approach I took next…

I’m hopeful that the Preferences subdir is the ticket. Maybe all the things and the stuffs will work now when I re-install build 2167 of Interface.

Those of you who are more experienced with this, please chime in if you agree or disagree with this approach. I started this thread to try to be helpful to the next poor bloke coming along and getting stuck.


#3

By the way, that didn’t work.

Still knows my login, still knows where I was last, still has a completely broken setup, no avatar appears, no scripts actually running.

I even installed a prior build version that I had not had before, such that I had to again go into Security & Privacy and specifically allow it to run. Still, it knew my login, and was broken.

So this is still probably only affecting me, and still not solved.

This is almost like (and it sickens me to say this) Windows REGISTRY BS. Where, for the love of Pete, is this Interface app hiding data that seems to thusfar be hidden from root on this machine? I mean, surely it’s not really hidden, but it’s not in a directory named “High Fidelity” nor in a directory named “Interface”. So where are you guys hiding it?

So perplexed.


#4

The missing piece lives in ~/.config/highfidelity.io/

get rid of Interface.ini from that path and your preferences will be wiped.


#5

Bingo. That worked for the remembers-my-login part. Thanks! Hopeful that’s the last bit, and I’ll be able to re-try with a completely fresh install of the latest build.


#6

Glad you are reinstalling and not going for good, KDOgg. And thanks for pointing out that I had failed to really really uninstall interface; I thought I had done so.


#7

Certainly not “gone for good,” @SterlingWright, but if this keeps up, may be on hiatus until…

  1. Things are a bit more stable.
  2. I can justify getting a beefy-graphics Windows system, plus another 25% of its value in anti-virus software (I’ve been 100% unix for several years now, and I don’t miss the malware battle one iota).

Here’s a shell script I’m using to clean out the cobwebs prior to launching Interface…

(deleted for stupidity reasons)

…and that seems to mostly work. Interface doesn’t know my login. Shows me the help screen (how to move, suggests my best headphones, etc.). And, it drops me at hq once I log in. Good and right. But all I see is white glow. If I spin around, I find this floating island…

…but up-arrow doesn’t bring me closer to it, PgUp doesn’t fly me up to its level. My only navigation is to spin, nothing else.

It’s alpha - I’m expecting there to be days like this. It seems a little odd that I’m having days like this and it doesn’t sound like anybody else is similarly afflicted. Hence, I suspect it’s not completely attributable to “It’s alpha stage, things will be rough.” More likely, I still haven’t found all the things that need to be wiped out to start over.

If it were me, to the extent feasible, I’d put everything in one folder, and its subfolders. And none of those folders or files would have spaces in the names… 'cuz escaping spaces in pathnames is so Windows95 “Oh, I can now use full sentences for folder names!” annoying. And I would tell my co-workers at the time, “Just because you can, doesn’t mean you should.” But I’m not bitter about being the NetWare Admin at a company full of layout designers. Not at all.


#8

Just noticed something dorky. Fixed that shell script.


#9

And now as of build 2169, this Mac Mini’s “Interface” is behaving rather normal-ish.

Onward.


#10

Glad you got all of that fixed, all I had to do was delete Interface.ini and it worked again for me Mac wise again.

Its good your script is there to help others but one suggestion i would make is to post it to a gist that way people can run it with bash <(https://gist.github.com/nbq/456a79528632c4476741/raw/32913d8841b06514d9a76fc878dfd908390f5109/gistfile1.txt)


#11

Great idea, but… the script I’d used the first time around was bad. As in, bad enough that I had to spend some time restoring from Time Machine. I figure it best to let someone even more Mac-experienced sanity check it before it becomes something copy-and-paste-able onto someone’s command line.