How to restore a downloaded backup on linux system


#1

Having a couple of servers running on Ubuntu I eventually managed to launch HiFi on both servers and having a working domain. The bad news is that when doing backup I apparently am not able to restore them via the http form since I got a server error exception, documented here in the forums and probably you are still working on that.
But, since I have ssh direct access to all the servers, I thought I can simply unzip the backup and put it back where it belongs. I’ve found various documentation teaching how to do this with Windows, but none related to Linux, is there any documentation on how to find the content directories and replace them via ssh with the .zip content?


#2

@claudio.pacchiega sorry, I am only seeing this now.
A patch is coming, I posted an update in this thread: Error while restoring a content backup

In the meantime, if you have SSH access and want to restore manually, you can follow these steps:

  • Make sure you have the archives you care about downloaded and stored in a safe spot
  • Uncompress the backup
  • You should get 4 items:
    • files (directory)
    • content-settings.json
    • mappings.json
    • models.json.gz
  • Copy all the files in the files directory into: ~/.local/share/High Fidelity/domain-server/backups/assets/
  • Zip the remaining 3 files (content-settings.json, mappings.json, models.json.gz)
  • Name the zip file you created backup-custom_archive-2018-05-22_13-42-51.zip
  • Place the zip file you created into: ~/.local/share/High Fidelity/domain-server/backups/
  • Restart the server
  • You should now see a backup name custom_archive in the manual archives section:
  • Restore it with the menu item on the right.
  • The server should automatically restart and you are done!

Let me know if you run into any issues and need some assistance.

- Clement


#3

Thanks a lot @Clement I will surely try this soon. This is really important to be sure we have a full control of our backups, and do not rely on the often buggy and megabyte limited possibilities of web browsers. Will try soon to create a copy of my domain on a different server, and let you know if it works smoothly :slight_smile:


#4

@Clement thanks,
I actually managed right now to use your instructions to move the domain now that we changed the server with a new one. It worked perfectly :slight_smile:

Thanks a lot for the instructions, and sorry for giving positive feedback a bit so late.


#5

Not a problem at all, glad it worked out!