Howto disable the fading on the edit window?


#1

Some complete uxseless new functionallit in interface. Fade in/fade out. If you like to put something very annoying in software then it’s fading like that.

So how do we turn it off or increase the speed , because it fade out to slow.
Oh no, it’s on all the windows. THIS IS TERRIBLE. :scream:

Yes it’s the first thing you turn off in windows too, because it slow things down and is annoying. Not understand why software need useless bling bling like fade in/out


#2

Are you referring to the transition when you open or close a window, where it goes from transparent to opaque? It’s not new at all. It’s actually been there nearly as long as we’ve had QML windows. I can’t imagine why it would suddenly be bothering you now. Also, it only lasts 0.3 seconds, so I find it hard to see how it could be very disruptive. If it’s lasting longer than that for you , please report it as a bug.

If 0.3 seconds is really too long for you, you can manually edit the fadeInDuration value in resources/qml/styles/HifiConstants.qml and resources/qml/styles-uit/HifiConstants.qml


#3

Yes that, well. i did not looked on the QML changes for a long tiome. so never seen it.
i Changed it. THANKS ! :wink: first tried 100 and changed it down to 20 , 5 , 1 and at the end 0 is fine because it still fade but on normal speed.

Only afraid that this parameter need to be set with every update ?


#4

Currently, yes. We might be able to add a mechanism to allow users to specify overrides for style things like this, but it’s not high on the priority list. You might add a suggestion to worklist and see if someone might be willing to do it.


#5

I just checked a few windows, i get the idea that the edit properties window have a different fade speed then the windows under menu -> settings. The last ones appear instant (fadeInDuration=0) But the edit properties when you open it with the edit button still fade on slower speed.

Let’s first clear out if all windows really uise the same fade speed.


#6

Before getting distracted by the fade time, I suggest the root cause be addressed, which is why does opening a QML pane cause the frame rate to permanently tank? I think this is the real issue here.


#7

Sad, just checked it but i do not see it on my system.