HUD Toolbar missing


I’m new to High Fidelity, and I’m using my laptop, rather than an Oculus Rift or Leap etc. I’ve managed to get inworld and can navigate clumsily, but apparently there is a HUD toolbar that is supposed to be visible. Is it just supposed to be there or do I need to unhide it somehow? I see no HUD.

Sandbox and Interface are both running.

I’m using a Mac laptop, running Sierra 10.12.3, 2.3 GHz Intel Core i7, 16 GB RAM, and NVIDIA GeForce GT 750M 2048 MB, and Intel Iris Pro 1536 MB for graphics.



Press the right mouse button. If correct a tablet will appear with everything that where in the hud before. Uhmm, only you use a mac and i did read you not have a right mouse button.


We don’t have right and left buttons, but we do have control-click which works for right-click. (Macs are fully capable computers.) And I have tried that. Nothing happens.

So, I connected my two-button, scroll-wheel mouse and went to the Play area. Apparently I can make things happen by clicking on them (when it says “click on this”), but I can’t grab, and the right button gets me no menu.


On the right-click not bringing up the tablet - that seems to be a new bug for Mac users in the recent Interface releases. @Caitlyn

On the issue of not being able to grab things when not in VR mode, indeed that is how it works. The bad news is that there is very little attention paid to making non-VR mode (aka desktop mode) work well in HF. For better or worse they are concentrating on the immersive experience. That obsession forces us mundanes to figure out how to script grabbing. There was one attempt at it, which worked for a while until changes to interface broke it:


Hi odd. Apparently the newest version of HiFi does not work on Macs. I have a MBP and an HP PC desktop. The update works fine on the HP, and not at all on the Mac.
No ability to load the scripts, and need to force quit to get out.

There is a meeting in world at 2PM Pacific, if you can get there, please ask, as I can’t usually attend these meetings.


The meeting is 1pm, the load test is 2pm


And i really have no need or mood to really jump in VR. Also my eyes are right now more happy without it. In the summer it’s mabye better. It’s more relaxed without HMD then with it. And it’s not always waring with comfort to.


:smiley: If I were to go to the meeting, I wouldn’t be of much use. I haven’t figured out how to hear or be heard without the HUD. Sooo… I don’t know what I could do except to stand around.

It sounds as if I should just call it a day and trash the app.


im on windows 10 and right click also doesnt bring up the menu tablet, but it brings up some kind of in-game browser window with “basic controls”.

need to press CTRL L to see “go to”.


Oh, hey! Thanks! Command-L gets me a few things, including the ability to go different places, and, apparently, to pick up a couple of wine glasses that I am now unable to put down.


I asked, they are looking into the problem.


Apologies for the delay on this. Recently we’ve been overhauling our UI system to be more consistent between desktop and HMD users, so we’ve inadvertently introduced some bugs on the mac build. I’ve created a PR to fix the main problem here. Please comment on the PR if this build works or doesn’t work for you.


HI,Thanks for this work. Here is my feedback:

BUILD 6055
Fixed: The sound seems to be fixed
Logout can be done without Forcing Quit
Cannot connect to most domains. (Yes, I am logged in) Protocol version mismatch (guess, because I am on this PR build?)
Connected to Labs and dev-Playa

Here I am on Labs, and as you can see, the HUD is everything double.
Was there not going to be a tablet? I can’t seem to make it appear.

Thanks. Franny