I hate the steam software sound setting messup :(


#1

Bah, steam is terrible designed.
It’s taking the sound settings away from the device when you not want it. (clicked by accident vive icon, not sure how it come on that spot) But it happens more times steam screw my settings. With the result that ypou n3eed to restart applications etc. because it jumped on the wrong soundcard train.

And the worse thing is that settings not always get reset to.
It would be better if the software do the changing , and not steam itself.

I think it’s really the biggest annoying point with steam.
It’s also bad point on the vivbe. , i would preffer to just have a line-in and line-out on the vive and connect it on the hardware i want how i want it.


#2

You just have to configure it properly, I haven’t had any issues when doing this correctly.

It is simple really. When SteamVR is active, the playback devices are set to the top part. When it is turned off, it returns back the settings you set in the lower one.


#3

Yup, but when you click by accident a vive icon that not belong on that location it takes the sound card away to. ANyway the playback device get sometimes screwed anyway. and you need to set it again in steam.


#4

But closing the SteamVR will revert all the settings to the one on the bottom. Its simple really, when using the head sets, you want to have audio on the headset output.

If you dont use the headset output, just set the Playback device to your own soundcard


#5

I think the mean problem where that close did not close but the vive icon hide in my taskbar. That’s why it mabye did not switch. I anyway where forced to restart minecraft to get sound back.


#6

The solution is indeed to set a mirror device in steam. That way i lose not sound when steam start. only volume can change. depends on how it where set before you logged out of steamVR.