I think it was just a lighting issue! ... Was - Changing the draw clipping distance?


#1

Alternate heading: “There’s a big black hole / Gonna eat me up someday” - Deep - Nine-inch Nails

Now I have my skydome’s texture rendering, I thought I had a distance-clipping issue (below image) but I woke up at 5am this morning after a particularly bad dream and thought ‘hang on - it is more likely a lighting issue!’ I assume that section of the dome is perpendicular to the scene default lighting source and so is in its own shadow.

I can likely work out how to fix that, either with an extra light or if there is a full-bright-like option in there somewhere.


Edit: below is not relevant to my issue any more but is left here for context of following comment:

I guess an entity property of ‘render no matter how distant’ might be nice too, for the low-poly overall-scene meshes I intend putting my close-up detail meshes on top of. :smiley:


#2

Hmm
"Render no matter what distance" is a bit exploitable. As long as its only enable-able by domain owners, then should be fine.

But how about domain zoning with simply predefined skyboxes (via domain management) that “fade” in and out when going out of bounds? that probably should solve the issue: and potential doable as we can tweak audio settings with bounds.