Interface and Sandbox not working after update


#1

Interface and Sandbox error. On start cannot find: api-ms-win-core-file-l1-1-0.dll ; api-ms-win-core-file-l1-2-0.dll ; api-ms-win-core-file-l2-1-0.dll ; api-ms-win-core-localization-l1-2-0.dll ; api-ms-win-core-timezone-l1-1-0.dll ; api-ms-win-crt-runtime-l1-1-0.dll I found them in Windows\winsxs folder and copied them to Program Files\HighFidelity and User\Appdata\Roaming HighFidelity. Now error is: the application was unable to start correctly (0x0000005) Click OK to close. Ive installed a new Strix GTX1080TI 11 GB Vid card recently but was happening prior. Been unable to log in to either since around update 6095


#2

Ive rolled back my Sandbox to 6618 and it works. Interface will not start to Go Home. I get the the “Dang” error and click don’t sent


#3

Can anyone tell me why no version of my Interface will work? I keep getting send error report error


#4

Ok, It sounds like you are not using Windows 10 and havent applied some of the updates available to Windows since 2015.

This is a known issue for many apps that have updated the build tools Like Paint.NET or with Adobe tools since 2016.

High Fidelity since Release 54 (7078) have been using new VS versions to build the client. Note that you will need to install the related updates for which ever Windows you are using.

  • Windows Vista -> SP2
  • Windows 7 -> SP1
  • Windows 8 - > 8.1

After the above, you should be able to fix the issue by installing Microsoft’s KB2999226 and use the latest version of High Fidelity along with other apps having the same issue.

If it is still having issues after that you may also need

VC++ 2015 Redistributable

The Libraries them selves should actually be linked to in Path, not in the same folder as your instance of Hifi.

Clean install of Hifi after should help as well. But it should work after doing the patches and repairs.

I hope that helps.


#5

Thanks many for the advice! With the Windows6.1-KB2999226-x64 update and Win Update turned back on it installed nicely. Then to the task of loading Lasted 7150 but server showed as working but localhost not working for Interface or web settings. Interface worked fine. I have both Sandbox and interface 7044. and all works fine. I lost all my environments and such in the fiasco. I’m Win7 SP1 sorry.


#6

Uff yeah it would have been a good idea to restore the domain backups if you had them.

In anycase, the server says its up but you are unable to connect to it? So were you able to connect to the web interface also? It is http://localhost:40100


#7

In the notification area,bottom right. Click on it - it had Go Home, Restart server etc but If I clicked on settings The page errored cannot find page\connect to localhost. So the server looked like it was running till i clicked on settings and saw sandbox was not connecting to the localhost.If I clicked Go Home interface tried to take me but could not connect. Using version 7044 of sandbox and interface all works as should. installing anything 7150 this happens


#8

BTW I may have backups What would I look for Sandbox backup files? I had to choose every time I reloaded HiFi whether to use current settings or Replace Avatar or replace everything. I don’t know which I selected in the end I was reloading dif versions more then 30-40 times


#9

Hi @anatta,
From your remark above, it actually doesn’t look like the server is running properly after all.
Did you see Menithal’s comment about maybe also needing
VC++ 2015 Redistributable
https://www.microsoft.com/en-us/download/details.aspx?id=48145

Also, have you had a chance to refer to this document regarding backups?

https://docs.highfidelity.com/create-and-explore/start-working-in-your-sandbox/restoring-sandbox-content


#10

I already have that redist C++ installed, thanks for the tip anyway. I’ve never manually backed up anything in HiFi yet. I keep all my assets on my own web-server. I retrieve assets from there so they are not lost. Everything runs fine 'cept if I update past 7044.