Interface crashes on startup on Windows 8.1


#1

When I launched interface tonight it informed me to download a new version, which I duly did. I did not uninstall the old version.

I launched interface and it loaded fine. However I decided I wanted to change my avatar, so I went to preferences and decided to do away with Evil Philip. I suspect this is the source of my problem.

Not long after that Interface crashed. When I relaunched Interface, it crashed. Since then I have a uninstalled Interface and reinstalled it, on launch it still crashes.

I suspect my Windows profile has some settings in registry as I have noticed that my avatar on my PC and Mac are different, suggesting some values are stored locally, but I simply cannot get Interface to run now on my Windows 8.1 PC.


#2

Are you running the latest version of the interface?


#3

Hi John, yes I am, when I logged in it asked me to download the newest version, indeed it said it was a required update. Version 1015.


#4

try installing a previous version and hit the “skip” button

then reset you avatar to the default avatar

then install the latest version, see if that fixes it, if it does, you can change your avatar back to what it was. Give that a try. It just worked for me.


#5

Hi John,

Ok I’ve done some troubleshooting and in my case the issue is when I select the lokibot body 2.

Now what I’ve noticed is that on Windows 8.1, when you uninstall High Fidelity it does not remove the appdata settings on the machine.

To find the appdata folder on Windows you have to change your folder settings so that you can view hidden files and folders, this will also be the same on Windows 7. Once you’ve ticked the checkbox to show hidden files and folders you will be able to browse to a location such as :

C:\Users\yourusername\AppData\Roaming\High Fidelity

Inside there is an ini file called interface.ini, it’s the only file in there on my machine.and is a file of type configuration settings.

The quick fix is to delete that file then start Interface again. You will be back to default settings.The file is recreated when you start Interface.

However if you’re feeling brave you can edit this file. Under the avatar section you will see lines that relate to the avatar you’re using. If you’re experiencing an issue where Interface crashes on launch, simply replace the head or body your avatar has with something like ;

faceModelURL="@Variant(\0\0\0\x11\0\0\0;http://public.highfidelity.io/meshes/defaultAvatar_head.fst)“
skeletonModelURL=”@Variant(\0\0\0\x11\0\0\0;http://public.highfidelity.io/meshes/defaultAvatar_body.fst)"

You may not need to replace both lines.


#6

Yep, I’m well versed with Windows, and there’s more stuff in there too. Assignment-client.exe is in C:\Users(username)\AppData\Local\High Fidelity\Stack Manager\ You’re going to want to know where that is at some point. Notice the ini file is in roaming\high fidelity and the assignment client is in local\high fidelity… also the search function skips these folders weather they’re hidden or not.

Thanks for the info though… it’s easier to tell people to just delete the ini and let interface.exe recreate it when they come back in, or you could probably get away with simply deleting the avatar lines you mentioned and save out the ini file. That’ll preserve other settings while resetting the avatar to default. good just hunting down the ini file though !


#7

For windows 7 and im sure windows 8
Open my computer, and left from the search bar enter.

%appdata%

Then your straight in the userdirectory, and you see the high fidelity directory.
Or for lazy people, do the following to get straight into the high fidelity directory

%appdata%/high fidelity


#8

Windows 8 doesn’t have “my computer” anymore. From the start screen you can just start typing and a search panel will slide in from the right.


#9

I know my computer is named different in windows 8, i think in classic shell its named "this "
I dont use modern UI on windows 8. just install classic shell.


#10

Ok a sensible fix has been applied, the body that caused the problem is no longer available. I feel a bit silly for not actually thinking of that as an option!


#11

I just ran into this issue on build 1401. I was using these values:

faceModelURL=@Variant(\0\0\0\x11\0\0\0\x43http://public.highfidelity.io/models/heads/Hifi_Mask_BlackWhite.fst)
skeletonModelURL=@Variant(\0\0\0\x11\0\0\0\x37http://public.highfidelity.io/models/skeletons/body.fst)

Resetting them to the default allowed me to run interface.exe without issues.