Interface simply doesn't start. It hasn't for many builds. Qt5Multimedia.dll is at fault


#1

For the past few builds I have downloaded, practically since @chris said DK2 support has been added, Interface has been unable to run.

The file “Qt5Multimedia.dll” is at fault.

I can’t really test the DK2 implementation with this issue in the way.


#2

@netverk and @Chris… note that the app crash I am getting since build 976 is also in Qt5Multimedia.dll
975 does not crash. All versions since in my windows 7 environment do. Though in an almost identical windows 7 system they do niot.

@Netverk, have you ever had an Oculus Rift DK2 and its runtime software attached to your system? Sound like you have?

Problem signature:
Problem Event Name: APPCRASH
Application Name: interface.exe
Application Version: 0.0.0.0
Application Timestamp: 53e919a4
Fault Module Name: Qt5Multimedia.dll
Fault Module Version: 5.2.0.0
Fault Module Timestamp: 52a4c768
Exception Code: c0000005
Exception Offset: 0000c7d0
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


#3

@netverk, can you try build 975 and say if that works. Then try 976 and see if that is the one where it starts to fail for you?

https://highfidelity.io/download/win/975
https://highfidelity.io/download/win/976


#4

What i’m noticing re crashes and weird hf things is sometimes when hf wont install its because when the update message happens and u click update the running version doesn’t always turn off leaving some processes running

also when interface does weird things ,it might be time to uninstall it all completely before trying to reinstall

Not saying you don’t do this stuff already , just mentioning what I try when things wont work.


#5

@Be_Austin and @NETVERK I am trying to reproduce your crash and not having much luck. Do you have QT installed anywhere on your machine?


#6

I cannot see any install of Qt in the Windows Control Panel “Programs and Features” list. I have never installed Qt directly, though of course it may have come with other software like the Interface.

All my tests and failures (and going back to working versions with build 975) have had the Interface as the last installed program.

I think that trying to reproduce a failure like this is not a good approach @Chris. It could be next to impossible given the combinatorics of different environments. It needs thinking to work out what MAY have happened at 976 that fits the reports. What would be good is if ANYONE has the same problem we may be able to identify the commonality.


#7

I assume you mean the Qt project platform… not QT as in QuickTime? Quicktime 7 is (like most people) installed.


#8

@Be_Austin yes QT project platform


#9

We thought so, hence see our reply earlier when we checked. No special install of Qt done.


#10

@Be_Austin Yeah, 975 is the last build that works.

Crash log:

  Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	interface.exe
  Application Version:	0.0.0.0
  Application Timestamp:	53e919a4
  Fault Module Name:	Qt5Multimedia.dll
  Fault Module Version:	5.2.0.0
  Fault Module Timestamp:	52a4c768
  Exception Code:	c0000005
  Exception Offset:	0000c7d0
  OS Version:	6.3.9600.2.0.0.768.101
  Locale ID:	2057
  Additional Information 1:	5861
  Additional Information 2:	5861822e1919d7c014bbb064c64908b2
  Additional Information 3:	d1d9
  Additional Information 4:	d1d94a13d3609d6b740644c12508f581

@Chris, I don’t have QT installed on this PC.


#11

@netverk, thanks for trying that. Good to have confirmation that more than one system is exhibiting this block level fault. And it seems like we are closing in on the issue.

@Chris can you ask @chansensturm who committed the (audio related) changes in build 976 to identify possible causes given the reports in a few forum threads on this issue (not just here), and possibly see if any change in use of QtMultimedia.dll possibly indirectly could be involved?

See especially this thread…

https://alphas.highfidelity.io/t/win-build-976-onwards-crashes-on-windows-7/787/

It has been blocking us for some time now. Be (stuck on 975)


#12

@Be_Austin @NETVERK can you give us the details of your sound card?


#13

There is no separate sound card… I think its on the motherboard. It is reported as “Realtek High Definition Audio”… the driver is dated 30/08/2011 version 6.0.1.6449.

I have an identical Windows 7 system at home which reports exactly the same sound setup and driver version, which does work with versions for 976 onwards. This home system has never had any Oculus software installed which is one possible difference.

I just did a driver update check and Windows indicated the driver was ip to date.


#14

@Be_Austin @chris
I also think I’ve got a on-board ‘sound card’.
It is a ‘Realtek High Definition Audio Device’ with driver version 6.0.1.7071, dated 22/10/2013.


#15

So looking at the console window when starting Interface, I noticed it crashed after saying something that basically suggested it couldn’t find a microphone.
As I didn’t have one plugged in, I plugged one in and now build 1015 starts fine!

So, @Be_Austin, maybe try plugging in a microphone!


#16

@NETVERK and @Chris… okay. I simply plugged in my USB headset and ran 1015 and it worked fine.

I stopped the Interface, unplugged the USB headset and restarted the Interface 1015 and it crashed in Qt5Multimedia.dll again as before.

Plugged the headset back in and Interface 1015 works.

Interface 975 works with and without a mic attached. Interface 976 starts the problem. So I don’t think we can now blame anything related to the Oculus Runtime or DK2 software.

The working almost identical Win 7 system I was using successfully all along happened to have a mic attached via a web cam that was plugged into it, so that was why one machine failed and the other worked, even though they were essentially identical.

My user Interface.ini file contains these lines… they seem to have entries for two different USB headsets that have been connected at some time to the computer (Creative HS-720 and Logitech USB headset). I tried deleting these entries and restarting without any mic or headset attached to force them to be recreated and it still crashes.

[Tools]
Audio\Use%20Speakers%20%28Realtek%20High%20Definiti%20for%20Output=false
Audio\Use%20Realtek%20Digital%20Output%20%28Realtek%20for%20Output=false
Audio\Use%20Headset%20Earphone%20%284-%20Logitech%20U%20for%20Output=false
Audio\Use%20Headset%20Microphone%20%284-%20Logitech%20for%20Input=true
Audio\Use%20Speakers%20%283-%20Creative%20HS-720%20He%20for%20Output=true
Audio\Use%20Microphone%20%283-%20Creative%20HS-720%20for%20Input=true

[Audio]
Use%20Speakers%20%28Realtek%20High%20Definiti%20for%20Output=false
Use%20Realtek%20Digital%20Output%20%28Realtek%20for%20Output=false
Use%20Headset%20Earphone%20%284-%20Logitech%20U%20for%20Output=false
Use%20Headset%20Microphone%20%284-%20Logitech%20for%20Input=true
Audio%20Noise%20Reduction=true
Audio%20Filter%20Bank=false


#17

Hello, the commit in question for build 976, should be disabled by default in the client UI, so the code path isn’t active. Make sure Developer:Audio:Enable Audio Filter is disabled and see if that makes a difference.

In general, we’re not doing a really great job of dynamically managing audio devices and format/device related buffer resizing. Overtime, we will address this. It is on my TODO list. In the meantime, please continue to post feedback.


#18

@Craig, I checked and I cannot see any key in the Interface.ini file for “Enable Audio Filter” in any section and I also looked with %20 substituted for the spaces of course. There are things related to audio debugging but not one called “Enable Audio Filter”.

Do you mean I should explicitly add an extra key? If so, can you clarify the exact line to add, I assume in the [Developer] section to my Windows interface.ini file


#19

I have found I must have a microphone of some kind attached to avoid the app crash in Qt5Multimedia.dll… but it can be a USB headset, a mic in a web cam or even a 3.5mm analogue audio mic.

It would be good to track that down and fix it so the app does not crash just because a mic is not attached. I usually let sound come out of my speakers, unless I want to participate in voice chat for a meeting. So adding a headset and redirecting the sound via that is not what I really want usually.


#20

@Craig, I can test this if you let me know the specific “Enable Audio Filter” disabled line to add into interface.ini for Windows. Be clear about the section it is to go in please.