Invisibility issues with Beta Release 19


#1

So why is my avatar invisible in this build?
its also killed the house i just built in the domain no one can get into

^this house not there after the update
so thanks for this


Beta Release 19
#2

My avatar was also invisible.
I think using a scattering map in my fst was causing it.
Are you using SSS on your skin?


#3

#4

No I’m not i tried it a whiles back but gave up


#5

Not that judas forgot todo it. But anyway, you did update the sandbox to ?


#6

The fix is in the mail… https://github.com/highfidelity/hifi/pull/8521


#7

The core issue seems to be a change in how we’re handling content due to fading. However it’s triggered by content that contains references to invalid textures. In this case that house is trying to reference a non-existent file newhouse23.fbm. Because that texture is never considered ‘loaded’, the fade in effect never starts. I’ve changed the logic to consider texture fetches that have completed (with success or failure), rather than just ones that have succeeded.


#8

My mirror stopped reflecting (ambient map) with this build


#9

Thanks for the fix :slight_smile:
I was googling fbm[quote=“Jherico, post:7, topic:11346”]
file newhouse23.fbm.
[/quote]

I initially thought that was a typo but no after looking in the logs yes I have a missing fbm, I dunno about you but I never heard of one of those before
however googling them lead me here
https://developer.blender.org/T44442
It seems to be a folder created inside a fbx to contain the textures.
So either Blender isnt creating it or hifi isnt able to read it, we have a workaround now but does it need looking at. Googling it and Blender i ran into the Daz people having problems with it


So It could well bite us in the arses when Daz comes to pass


#10

The reflection thing could be to do with the new inclusion of Bloodlines into the code, you need to buy for only $5 a special garlic necklace that will prevent the current situation :wink:


#11

As Judas mentions; Daz / HF Devs / and all content creators… heed this warning… well, that is unless you have the deep pockets for Maya and Stingray; :blush: then forget we said anything. :stuck_out_tongue:


#12

What’s the fix. working on mini golf. upload my latest version.
Invisible ! in FBX viewer everthing looks fine. The entity is available, i stay on it. But i do not see it ! :unamused:

Beta 20 not fixt it for me.


#13

Can you post a link to the fbx?


#14

After hours of searching i found teh problem. It’s a user error but also a high fidelity problem. for soem rwason TGA texture got in my project and that made everything invisible.

I made issue on github. also there’;s a demo box with TGA texture on it that also not load.

https://github.com/highfidelity/hifi/issues/8578