Is here somebody, who runs hifi on Ubuntu?


#1

I try to run hifi on Ubuntu 14.4. QT5.4.1 is installed.
The sources are compiled, the port is opened and forwarded.
The domain-server and assignment client is starting in a screen. The nodes are running. I can login and get connected. After a short time the nodes are killed and the place isn’t connected more.

So I would like to know, if somebody was able to run hifi successfully on Ubuntu.


#2

I have got a pc with ubuntu 15 on it and can run a domain. I can upload from the marketplace, they are still there when I log on and off.
Hence even managed to get a graphical stackmanager running on the kde desktop :smile: (still figuring that one out)


#3

Huhu, in this way I have got to run it. May you find a missing part.

https://alphas.highfidelity.io/t/linux-server-fix-how-to-install-hifi-server-on-ubuntu-linux/6857


#4

Oh well , it seems you run it at a local host.
I try to run it at a VPS connected with a domain and a place on hifi. On this way also other can login at your place.


#5

Is it possible that you’re somehow saturating VPS throughput? (which might be less available than expected if being QoS throttled or have chatty neighbors)

My overall guess is that these symptoms have something to do with thwarted UDP hole punching (pinging), bandwidth saturation and/or NAT routing issues.

I first saw this kind of disconnect sporadically while running domain/assignment and accessing over local WiFi (using two Ubuntu machines), but never found an effective way to reproduce (or to trace the interwoven networking code paths).

About a month ago both machines began exhibiting the symptoms regularly though – somehow correlated with multi-avatar situations. Like the weekly meetups began 99.9% consistently booting me out – I could initially get in and hear people talking for a brief while, but then in about a minute get disconnected with “server going away” log entry. At the time since nobody else seemed affected I figured this was just my slow broadband connection (15MB/1MB) failing to keep up with the increased number of avatars.


#6

Chris sent a link about Ubuntu in my post:
https://alphas.highfidelity.io/t/unconnected-domain-server/6999/3

The link:
https://alphas.highfidelity.io/t/ubuntu-installer-script-beta-info-about-centos-errors/6887


#7

@humbletim well I have two servers and at the other I run 9 Osgrid islands at the same time and hasn’t had some problems, so that shouldn’t be the problem. At my local host at my Mac I became not logged out at the meeting. So this also seems to be ok with the interface.

@JuelsDreki dos somebody run hifi on a VPS with this script?


#8

I also have no problems running other software over WiFi or with my broadband connection, so unfortunately the fact that other software runs fine (even seemingly-similar software like Osgrid) does not itself seem like a strong indicator of a HiFi-compatible networking layer.

Have you monitored the bandwidth displayed in Interface Stats while the disconnect occurs?

If you pull up the Stats and click for additional details there should be a bandwidth readout. What I noticed was that initially steady bandwidth is reported in both directions – then within a minute or so it drops very significantly (but not to zero), and then a second or two later the Servers count drops to zero along with Interface finally showing DISCONNECTED in the title bar.


#9

Well I have tried much with the iptables. No clue, if this is all right now. But I can login and be connected. Then I get in debug:

[DEBUG] [08/21 17:11:04] [4274] [entity-server] Hit PPS Limit, packetsSentThisInterval = 1 maxPacketsPerInterval = 1 clientMaxPacketsPerInterval = 1
[DEBUG] [08/21 17:11:05] [4274] [entity-server] Killed “Agent” (I) {aa2a12c8-ae28-435d-b3f3-469031c7202c} 62.158.76.75:57247 / 192.168.2.103:57247
[DEBUG] [08/21 17:11:05] [4274] [entity-server] Entity server killed node: “Agent” (I) {aa2a12c8-ae28-435d-b3f3-469031c7202c} 62.158.76.75:57247 / 192.168.2.103:57247
[DEBUG] [08/21 17:11:05] [4274] [entity-server] Entity server [ EntityServer(0x2bb0e20) ]: client disconnected - ending sending thread [ OctreeSendThread(0x7f15f40459a0, name = “Octree Send Thread (aa2a12c8-ae28-435d-b3f3-469031c7202c)”) ]

Well [entity-server] Hit PPS Limit, packetsSentThisInterval = 1 maxPacketsPerInterval = 1 clientMaxPacketsPerInterval = 1

No clue what there is to do.


#10

Sorry, I have not yet tried the Ubuntu scripts.