Is there a confirmed workflow of getting fuse/mixamo avatars into High Fidelity?


#1

So I’ve created this cute little avatar using fuse/mixamo, had it packaged by the interface and put the .fst on dropbox.
But when I now finally try to load it, nothing happens --> the progress bar shows up for no more than two seconds and the blue standard avatar pops back up again.

I also tried Judas’ workflow (Blender to HIFI Avatar workflow and they said it would never work) in blender, but the .fbx is already all messed up there when being imported.

So I’m wondering if there is now an updated and confirmed workflow for getting fuse/mixamo avatars into High Fidelity?

Also I have two newbie questions regarding the mixamo export:

  1. What kind of .fbx is the best to choose - the standard one or the one optimized for unity?
  2. Is it normal that the .fst is just 5kb in size?

Thank you very much for all your help in advance!
(And sorry if this has been a double/triple/quadruple post regarding this burning question :wink: )


A noob's cry for help on importing a newly dressed Mixamo avatar into High Fidelity
#2

Judas’ workflow should work fine to date.

Although its a tad bit out dated, as you may get the skeleton stuff to get in the way. Here is my Blender tutorial I made a in the summer, when the skeletons binding method changed, which made some things a bit more complicated due to having to reorient the bones to an Absolute T pose.

To put it simply, the fst file that is generated is just an file to point to the model and the texture files, and bind the shapekeys / bones to the High Fidelity’s skeleton.

Just make sure to upload both the fst and the folder it creates to your hosting solution, and then check if both the fst file and the model are in places which you can access with the browser.

  1. Use standard
  2. Yes, its just a pointer file.

#3

Thank you so much for your quick response, dear Menithal!

I’m trying my best now, but I still encounter a problem:

Although I did install the script you linked to in the youtube comments it always says:
“modifier cannot be applied to a mesh with shapekeys”

I even tried to get this working with the previous (2.77) version of blender, but there it seems that the script can’t even be installed (it doesn’t show up in the list after hitting install from file)

Is there a way to solve this shapekey/modifier issue by hand?

Best wishes and thanx a lot again :slight_smile:


#4

Oh, ill check out what was with it, it should have worked, but its been a while.

Unfortunately the shapekey binding process is a lot more tedius to do by hand, but in the gist of it:

From Blender StackOverflow

  1. Duplicate the object “A” to “B” and remove Shape Keys from “B”.
  2. Apply modifiers on the duplicate “B”
  3. Duplicate the original object again from “A” to “C”, with a Shape Key transformation (choose one for now. we have to repeat for other Shape Keys)
  4. Convert the second duplicate “C” to mesh using Alt-C “Convert to - Mesh from Curve/Meta/SurfText”
  5. Select “C” (as selected) and then, “B” (as Active).
  6. In Properties - Object Data - Shape Keys, we click in the down arrow and, in the menu, we click in “Join as Shapes”. This will create the “Basis” with the original shape and a second shape key, with the same name as the object. Now, we have to change manually the name of the Shape Key.
    “C” can be deleted. Repeat for each Shape Key.

Which is why its better to use the script :D, Will need to check whats wrong with it, but its been a while since It was last updated.


#5

Hoooray it worked :champagne::smiley:

Being a bit awed by the do-it-by-hand-workflow I went for a try with Judas’ workflow again and made sure that the blender version was exactly the same as his (2.76b) and that structure of the folder packaged by the interface didn’t get messed up by dropbox.

Now I have my very shiny and cute avatar to finally jump into action :slight_smile:

Thank you so much for all your input and advice!


#6

If you did anything different to get it working stick a note of the changes in the forum

Ill have a look at bringing an avatar through the current Blender to check what happens

were on shifting sand with both blender and hifi


#7

On some of the blender versions the script didn’t work.
But being a first-time-blender-user and also quite new to rigging/animating objects, I guess the problem was more that I didn’t follow your instructions exactly enough :wink:
And I didn’t upload the whole folders to dropbox at first…
So probably this “bug” is on me :stuck_out_tongue:

Still thank you soo much for this great video tutorial!!
I’m so happy that the avatar finally worked :slight_smile:

And I’ve been really stoked flying through the welcome area today :sunglasses::smiley:

Thanx so much to everbody for their help and warm welcome there😍
This place is amazing!!