Issue with chat by pressing enter. Unable to chat


#1

I am unable to initiate the chat feature and it is greyed out in the tools menu. When I press enter for the first time upon login I following box on the right.

Connecting to Xmpp…

The box goes away after a couple of seconds and when I hit enter again nothing happens. I am unable to chat.

Is there a fix for this? Thanks!


#2

Does anyone have a fix for this as it appears the Xmpp service wont start in windows.


#3

Hey Kevin, if you logout and login again while the client is running, does the window open again after you relog? Thanks for helping us track down this bug.


#4

Hey Ryan after I log and log back the issue still occurs. it hangs on connecting to Xmapp


#5

Ryan after deeper inspection, I am not even actually logged into the world. I am in the server and I see everyone and everyone sees me but I am technically not logged in. This is a windows build bug of some sort. Can you check on your end to see if my account is an issue perhaps becuase its KevinMThomas_Ca and there is a dash.
I asked Emily to delete my account and she did and I resigned up as KevinMThomas however even when i cleared my cache and I log in as my new KevinMThomas it shows me as KevinMThomas_Ca in the https://alphas.highfidelity.io


#7

Hi Ryan here is a console view of my issue.


#8

It looks like the account is in tact its a problem with logging in.


#9

Hi Ryan - issue resolved.

I had to make sure the dll files above with OpenSSL were connected in the QT bin directory.

I am now able to successfully login and utilize chat.


#10

Interface 393 on Mac

Can’t chat
I hit enter - chat window appears - I need to logon ?

Though I’m already logged on, It seems chat is a different system
I login - no error - but no chat enabled

Maybe not present yet in the Mac build ?


#11

I have problems with running chat to, its on windows system.
Would be nice to have option in the menu to open chat. so you can verify things.

Not excluding that something is still wrong here.

Note: i see that qxmpp is missing. going to fix that.


#12

@Robertus and @Richardus_Rayma Did you manage to get chat working for you?


#13

Right now, no.
Because qxmpp is not available as precompiled librarys.
and QT creator abort when building qxampp. so the library’s never appear.

if there where pre-compiled qxmpp library’s available for
windows things would be moveing again.

Right now, stuck on compiling qxmpp.


#14

What’s the Problem? At which point does it stop working?


#15

loading qxmpp.pro in QT creator. pressing configure. then say build all.
After a while i see the gollowing error.


M:\qxmpp-0.8.0\tests\qxmpputils\tst_qxmpputils.cpp:59: warning: C4309: ‘argument’ : truncation of constant value

M:\qxmpp-0.8.0\tests\qxmpputils\tst_qxmpputils.cpp:59: warning: C4309: ‘argument’ : truncation of constant value

Maby im confused and this are only warnings, useing QT creatore for the first time.
But i never can run install or find the /include /lib etc back.
expect thats saved back in the qxampp directory.

More i have not figured out right now, this try is with qxampp 0.8 but 0.7.6 is not better.


#16

@Chris No, chat not working
Now on Mac Interface 404, same behaviour


#17

Looked deeper into qmake on the console with debug parameter. And its looking for something on wrong place. Need to look later into that problem more.

DEBUG 1: C:\work\build\qt5_workdir\w\s\qtbase\qmake\generators\makefile.cpp:376 Failure to find doc/html in vpath ()

Maby someone have a good hint. Ther’s no C:\work\build\ on the disk.


#18

Ok, the above error is fixt. now having the dll, the lib. the include file.
Copied everything to the hfi library directory. and still it keeps saying.

– Could NOT find QXMPP (missing:  QXMPP_INCLUDE_DIR)

So, added for safety QXMPP_INCLUDE_DIR to the Environment variables. offcorse thats not needed. checked the cmake file. everything seems fine. and still it cannot find the file.
Here’s the qxmpp directory structure. Everything seems fine. still hifi cannot find it

The dll i moved in the directory to , to find it easy back.

-----
 Directory of ..:\Librarys\qxmpp

2014-04-25  13:45    <DIR>          include
2014-04-25  13:43    <DIR>          lib
2014-04-25  13:34         1,036,800 qxmpp0.dll
               1 File(s)      1,036,800 bytes

 Directory of ..:\Librarys\qxmpp\include

2014-03-26  10:30             8,026 QXmppClient.h
               1 File(s)          8,026 bytes

 Directory of ..:\Librarys\qxmpp\lib

2014-04-25  13:34           733,912 qxmpp0.lib
               1 File(s)        733,912 bytes
-----

#19

Found the problem, this sounds like a bug.

the QXmppClient.h need to be in [libraries]/qxmpp and not in [libraries]/qxmpp/include


#20

Do you have skype? I can help you sort it out or is everything working now?


#21

Its working now here. see issue https://github.com/highfidelity/hifi/issues/2730
looks for me like a error in the cmake file.

After the change in the cmake file i have copied the

/base
/client
/server

*.h files to include directory for hifi, and the lib file to the lib directory
then its working for me and the chat opens when am hitting enter.
except its keeping hanging on connecting to qxmpp. look at that later and try a newer build.

Why is there no option to close the chat window if it cannot make a connection?