Iterface Mac crashes on start up after version 1821


#1

Hi,

The latest Interface I can run on my MacBook Pro is v. 1821, after that version the app crashes on start up, it happens in OSX 10.9.5 and 10.10 in the same machine, I’ve tried deleting all files and doing a clean install, any help would be appreciate it,

Here are the problem details and configuration:

pastebin crash report


#2

@ncsolar thank you for full crash report - very helpful!

@leo is guessing this happened thanks to upgrade to OpenSSL 1.0.2 and is going to downgrade back to latest 1.0.1 for now.


#4

@b Thanks for the reply

I made v. 1856 work by using brew to install openssl 1.0.2 and replacing libcrypto.1.0.0.dylib lib that came with it, into Interface.app/Contents/Frameworks

I’ll report later how stable it is


#5

Oh, that would make sense. I’ll double check if we weren’t linking the wrong dylib for 1.0.2


#6

I’m unfortunately having the same issue. Monday 2/23 built from git source and was working. This eventing things not working with 1856 or 1877.

crash report: http://pastebin.com/3a9b9Haw


#7

Please download the latest version (1879 for Mac) - the issue should be solved — I’ve reverted to system OpenSSL, not an actual solution just a way to avoid crashing until I figure out what’s getting busted in the copying/linking of the ssl dylibs into the app bundle.

L


#8

i’m not sure my last reply went through so apologize for double post.

The issue persists with v1879 - http://pastebin.com/M7zGHsjX

I’m not sure if my openssl is messed up now after trying to update current .98 to 1.0.2 via brew and then tried to downgrade via brew to 1.0.1.

currently at 1.0.2 but still crashing on open


#9

Hi @balbert this could be a different issue. Could you try and remove your Interface.ini .

MAC - cd ~/.config/highfidelity.io/
rm interface.ini

Let me know how you go with that. Did you recently change your avatar that started the crash?


#10

still no luck. it starts, i see the intro screen and then it just closes. I’m also not getting a crash log to come up. Just quits.

correction did get a log http://pastebin.com/W6nH4v4Z

@chris sorry didn’t see your other question. I built from source on Monday night on my PowerBook and things seemed fine. Used it for a while but it did ultimately crash at the end when I was done.

Yesterday i download the alpha program build onto my iMac at work. Did a bunch of exploring and also edited my avatar by loading a head/body from the list in preferences. Also did some console scripting and loading scripts. all worked fine.

Yesterday evening went back to my laptop and that version wouldn’t start. My iMac at work version works fine again today with old 1866 as well as the newly updated 1879


#11

@leo 1879 for Mac works for me now I was able to log in, OS X 10.9.5, 2.8 GHz Intel Core 2 Duo, NVIDIA GeForce 9600M GT 512 MB


#12

@blabert , does your home machine have anything plugged into any USB’s. If so, could you try removing. Want to make sure @leo also sees this.


#13

@balbert do you have any brewed or otherwise installed openssl version in your system?