Judging size and scale?


#1

Curious question regarding the scale of objects. When making things for SL / OpenSim I would always judge the size / shape of the object I was creating by first roughing it out in prims in world, exporting to Blender, and then creating my mesh around it. Obviously prims don’t exist (yet?) here on HiFi and there’s no way to export the shapes created in world. So how does one judge the size and shape of things between the world and your modelling software? I’ve read that 1 unit in Blender = 1 unit in HiFi but so far had horrible luck with that where a step that measures as .1 units in Blender comes out to nearly half the avatar height after imported.


#2

Prims in SL are predefined mesh objects with some predefined transformation parameters. The closest HF equivalent are the built-in box and sphere entities. They are resizable, rescalable, colorable and that’s about it.

Click on the edit button right of the screen, just below the upload button there is a box icon and a sphere icon. Good luck on editing objects. It used to work fairly well months ago, but it is pretty much entirely broken at this point.


#3

try pressing reset to natural dimensions in entity properties. Hifi uses meters a 2x2 cube in blender is the same as one in hifi


#4

I’ve had … fairly good luck mapping scale in HiFi… I use 1m HiFi = 1 unit blender = 1m RL… and avatar scale = 1.

But when dealing with large objects… or sometimes nonuniform aspect ratios make sure after you upload it to HiFi, you select it and in entity properties, click on the Reset to Natural Dimensions button.

For some reason some large models import smaller than they should or squished to a cube.

Here is pic of default blender 2m cube imported into HiFi.

Ooo.,. and make sure scale of the object in blender is 1… otherwise is scale * dimension.


#5

You need to set Blender to Metric Units.
Blender at default is set to Blender Units which I’m not sure what it is exactly, its neither Metric nor imperial

Check your Units as per the first step in the pic below, if it is set to None, theres the answer. Change that to Metric then one blender unit becomes one meter and the rest is as written above, make sure you export at Scale : 1


#6

I was wondering how long it would take someone to point this out… o.O


#7

Awesome sauce, thanks gang! Setting Blender to Metric was definitely the missing piece. :smiley: Meanwhile resetting natural dimensions looks to be an awesome help for when I’ve rather lazily been updating the file on my server and just forcing the interface to reload instead of actually re-uploading the entity into the scene.

I now have much to tinker with tonight after I’m done frying my brains with C# code for my day job. :slight_smile: