Localhost access problems


#1

My client is often, but not consistently, refusing to log into my server at localhost (both compiled from the same git-pull).

Clearing the client settings dumps me back at Alpha, which seems happy enough with my login. Jumping back to localhost leaves me ‘not connected’. The edit tools report I don’t have permissions to edit here (expected for a non-connected state). No nodes related to my client are listed in the Domain Server web interface.

If I restart the server while leaving the client running, the client ‘connects’ while the server is restarting, then goes back to ‘not connected’ mode. However I can now use the edit tools from the client. Client nodes briefly appear in the Domain Server nodes list then disappear again.

I have tried with both permissive access and access restricted to just my own user name. Behaviour doesn’t change.

I have also tried access via the domain name registered with HiFI which points back here correctly but the behaviour is the same.

Yesterday (same build) I was getting periodic lasting ‘connected’ states during restarts of client and/or server but with no consistency.

This is current git build on Debian/unstable GCC5.

Update:

I turned off ‘Restricted Access’ and now I have access. My username is (and always has been) in the ‘Allowed Users’ list.