LOD goes to 0.000; FPS doesn't fully recover


#1

Windows build 2143
Frame rate unlimited
VSync off
Place with 80+ FPS

Running Scripts > Load from Disk … leave file selection dialog box open for a big
LOD drops down to 0.000
Cancel out of dialog
FPS gets stuck on ~25 FPS even though nothing is being drawn (apart from the star field)

Have to restart Interface to get a decent FPS again


#2

Same problem LoD drops to zero in seconds, only star field remains visible.

Windows 2161
AMD 6-core CPU
8 GD RAM
NVIDIA GTX650Ti
Windows 7 Home Premium SP1


#3

Me too… at even seemingly randomer times. And like was said… does not seem to recover. One way I’ve fixed it is to leave LOD tools window open… and set to 20:20… If i leave it open is sticks… otherwise starts again.


#4

Sorry about the roughness of the LOD behavior! The latest release build has some big improvements, at least for the testing I’ve been able to do. @ctrlaltdavid @Simulacron3 @Twa_Hinkle can you see if it works better for you? We’re going to also add resetting LOD when changing domains, which should further improve things.


#5

Seems to work better for me now. One thing I’ve noticed is that when I bring another window/task into focus, I can see Interface FPS go way down. Disabling the auto LOD when interface is not on top might be good.


#6

Still getting the same or similar problem to that I reported above …
Windows build 2162

FPS unlimited, minimum desktop FPS = 30
Place with FPS > 80 (e.g., just starfield and own avatar pretty much)
Running Scripts > Load from Disk … leave file selection dialog box open for a while
FPS drops down < 30 while the Windows dialog is open (not unexpected)

Cancel out of dialog.
LOD immediately starts being reduced because FPS < 30.
LOD goes all the way down to 0.0
FPS never recovers (stays stuck on 24FPS)

This may be a corner / overlooked case; low FPS while Interface isn’t in focus because have another program open seems to recover to high FPS with no reduction in LOD when Interface regains focus.

@philip


#7

David, I tried your repro case. And I am not seeing the drop to 30fps when the open file dialog box is open. I don’t see the LOD drop upon closing the open file dialog.


#8

@Twa_Hinkle - note: when interface is not the top level app the FPS is designed to drop to ~15fps… and we ignore that FPS for any LOD calculations. If you are seeing otherwise please let us know.


#9

When I log in everything rezzes, but after a few minutes the LOD goes down to 0.00 and FPS runs down to 0.00, and does not recover. Even the avatar disapears


#10

I fixed it by manually setting it


#11

You might want to check your fps rate setting: this is a legacy sorta issue, but it still occurs when ever there are too many complex objects or if your hardware is struggling.

If the client cannot meet the FPS setting set in this, it will lower down the LOD until it meets it: as of the moment however many objects do not have LOD levels.
You can find this “minimum fps” under Settings > LOD: By default it is set to 30 fps.


#12

The auto-LOD just does not work well if you are using anything less than an 960 GPU. It’s too aggressive. It’s goal is to keep the frame rate at or above whatever you set it no matter what it takes to do that. So, for the high end graphics cards, it usually works OK because there it is dealing with temporary overloads. But for any less capable graphics, its default setting will always reduce the LOD to 0. If you are not blessed by ripping fast graphics, it is best to set it to manual.

There is also a bug nowadays that if you open a QML window (and that is happening more and more as things get converted to QML), you FPS will tank to zero almost immediately, and, worse, not recover.


#13

would that explain why i have quite a bit of lag?


#14

Depends. What graphics card is in your computer?


#15

my laptop has GTX 850M and Intel Graphics 4600. But the Nvidia graphics is set to Default