LOD tuning and "warning" message are now in the latest build


#1

Feedback is welcome.

Here’s what has changed:

  • The old LOD adjustment would stop when your “equivalent vision” got to 20:80 vision. Now it will continue to drop and drop and drop util nearly 20:infinity vision… meaning totally blind. If it gets to that level, then all entities and all avatars will be invisible to you… they won’t render.
  • The defaultScripts.js now includes an LODWarning.script that will display a Warning (as a 3D Text plane 2 meters in front of your camera) when the LOD drops. It will show that warning for a couple seconds after the LOD stops dropping. It does not show a message when LOD increases.
  • The “window to consider Lowering” has changed from 5 seconds to 0.5 seconds. This means that once the LOD starts to drop, we will drop more quickly until we reach 40 fps or better.

In practical terms this means that in places like Apartment, if you’re on a machine that can not maintain 40fps, then parts of the scene will start to be hidden. Those parts are the smaller meshes of the apartment (and/pr smaller meshes of the NPC characters in the apartment). For example, the Rasta dude will lose his facial features. If the fps is above 55fps, then the LOD will steadily increase.

There aren’t any substantive changes to the algorithm… its the same we’ve always had. The only real change was the “minimum LOD” we will adjust to.


#2

lodwarning.js didn’t load in automatically for me dunno why not.
Still getting the c++ crash tho at rivenglen and the house with people after months and months @chris
updated my graphics card to a gtx970, so im not underpowered or outta date


#3

Would it be possible to set walls to res first? If making a game and the prize is behind the wall, an LOD event could show the prize and give away the game.


#4

I too have had the experience of LOD to blindness and I think that it is something that would make a person new to HiFi just quit in frustration.

I see at least three problems with the current implimentation:

  1. There is no way to tell what is causing the poor FPS so the only solution is to turn off auto LOD.

  2. Sometimes FPS issues seem to be caused by other things happening on your machine not related to HiFi. For example, if you have other gpu intensive programs running at the same time or many browser tabs open that all start playing video ads.

  3. When I’ve seen it drop down to zero, there were not very complicated scenes being rendered. So either something was corrupted in my domain or HiFi will only be able to render simple models etc., which would sort of make it a step backwards.

Although I know that the goal is to keep FPS high so that all interactions have minimal latency for better immersion, One thing that might help is to only turn it on when in HMD mode.

Makes me think of new grief method “Look at my attachment… and go blind”