Mac Woes /PC Woes, too


#1

Hi. On my mid-2015 MBP:
Model Identifier: MacBookPro11,5
Processor Name: Intel Core i7
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP114.0172.B06
SMC Version (system): 2.30f2
Serial Number (system): C02PQ5UEG8WM
Hardware UUID: 5B93A60E-0BB3-53B2-9050-E1779ECB01F2

As of this writing, I am on the newest build. All of the large terrain models I bring in show as black, but others can see them textured.
Then, I brought in a model, and switched to my PC, but the model…on my MBP High Fidelity viewer shows black, while the PC does not find the model at all. I retried several times.
I understand that Macs are not the priority any more, but until I get my Vive ready PC, this is my newest and most powerful machine.


#2

Have you tried setting your LOD manually?
[edit] Nevermind. I went there and it’s not an LOD issue.


#3

I had black models using a testing machine that happens to be running ATI Graphics. After upgrading my models to PBR in Blender, the items renewed correctly have shown, whereas anything missed is still black. (deck chairs black, but deck shown) Have you followed @Menithal video?


#4

To note, they did do some changes to the PBR rendering yesterday so some stuff may have slightly, mostly involving the textures fully overriding the colors (it seems it doesnt fully do this anymore, instead the some values are multipliers when textures are set)


#5

Hi. If it’s about the lack of PBR, why does it render fine on the Windows machine?


#6

PBR is a graphics card thing, not a Windows versus Mac thing. I’ve gone into Blender and updated my chairs and a few other items for use with PBR:


#7

So glad I paid all that money for a Mac that can’t render PBR. Yay me.


#8

That could be the issue, but for me, I simply had to mod the material in blender so the graphics card knew what I was trying to “tell” it. :smiley:

What graphics chip is in the MBP?


#9

If you can, grab @Menithal torch. If it renders for you within your domain (or wherever the black terrain stuff is happening) then you know it isn’t the machines fault, and you will need to update your model in Blender or wherever it came from… CityEngine maybe? :wink:


#10

OK, so I went to @Menithal’s place, and everything there rendered fine except for one of the torches (I think the one that has the emission on it). I know the hairball is PBR, so I am at a loss.


#11

Ok, so let’s analyze what we know from this:

  1. You machine IS capable of PBR.
  2. SOMETHING is causing black (you mention emmisive property)
  3. Your Terrain is black (probably the same issue)

Did you see the thread about the white-out @Ai_Austin was having?

If your Terrain is showing up black, then you need to mod the terrain material in the 3D Modeling Software you created it inside of. I noticed that it “appears” to be from CityEngine, so that’s why I mentioned it above.

Keep us posted.


#12


strange shadow


#13

That’s just Mr Rectangle - he’s our guardian!


#14

CC: @DrFran: you should come revist. everything you see is already rendering with PBR. So if you see anything it is working to some degree.

The Torch you looked at that was black had missing textures (because i removed the texture references) I created a new one that has the emissive maps again…

It seems like when the Glossiness/specular intensity value is set to 1, causes the blackness (the last spheres are black too where the glossiness is completely gone) Ill try this with my work macbook pro (also mid-2015) tommorrow


#15

This is the weird shadow, the only shadow u can see with the rift on, wonder whats throwing it?


#16

No idea - it’s been variously blamed on overlays, the progress bar for content loading and other things. But that logic fails as it is present with no scripts running at all and is present in an entirely empty domain but for having a single cube entity for shadow to fall upon. Its visible location changes with hour of day setting precisely as a shadow cast from objects - it also appears to be somewhat offset vertically positive. The mini mirror gives a different perspective of it.

Since it moves with your avatar always leading it if you’re at right yaw to see it I still believe it’s coming from something to do with AV. Figured - ok… it’s a me thing since I’m using my hacked AV that probably shouldn’t even work let alone work well… Tried multiple variants from MP and continue to see it. I’m posing a video of Mr Rectangle in bug tracking system once QuickTime finishes compressing it.


#17

#18

Yup - Mr Rectangle loves you too.


#19

Apparently. aliens.


#20

OK, So I made a test model of a terrain using PBR, brought it into HiFi, and all seems to function. I hadn’t intended to use that old model anyway, so I suppose I am fine. It is a bit odd that these things render black, but it must be a function of my graphics card, and not the lighting in my domain.