MegaVoxels? appearing in front of me in the sandbox


#1

I am witnessing strange behavior in the sandbox, MegaVoxels are appearing in front of me.

I am playing with the script found in Examples "particleBirds.js"
timestamp approx 2014-7-20-t18.54.00
location #particleBirds test

I ran the script without issue several times, made minor changes to such params as
var birdLifetime = 20;
var range = 1.0;
var BIRD_FLAP_SPEED = 10.0;
var BIRD_VELOCITY = 0.5;

I changed the velocity and that was fine, I changed the lifetime and that was fine,
I changed the FLAP_SPEED to 20 and birdLifeTime to 10 and then it all went wrong.

Firstly the particles only lasted a single frame before disappearing yet the script continued to run according to my “running scripts” the consol showed no errors that I could see.
I stopped the script and returned the values to default and restarted the script, the particles only lasted a single frame again then disappeared, but now I noticed a voxel appear near me ( I have voxels script running but not active)
as I rotate the voxel disappeared and another appears, different colors, all seem to be 1m size.

Suddenly about 30 seconds later a few particles begin popping in and out, various colors lust like the bird script but the bird script is no longer running, then it gets worse.

Voxels begin popping up all around me all colors, and disappearing again until a big pink voxel appeared, my guess is about size 16. Then a huge blue voxel appeared beneath me and for a brief moment I was surrounded by various colored big voxels, I backed away to ge a better look and it all just snapped into a massive voxel (bigger than 16 possibly as big as 64 couldnt really tell) now I am thinking I blew up the sandbox.

I relogged. (sweating, heart pounding)

The big pink one is still there, as I move around more appear, some disappear, now there is a massive purple one and lots of little ones and I see the odd particle ball pop in and out, as I move around the scene changes, these *voxels have a mind of their own.
I say *voxels because they dont behave like a voxel, they are cubes but I cant edit them with my voxel tools, they simply dont register, its as if they are particle cubes, so it is probably not our well known megaVoxel bug but it could be related. Thats as much information as I can think to share.

I named the location “particleBirds test” to see if anyone else sees the same result there.


#2

Some images


This suddenly became this…


#3

Attempting to reproduce the bug,
I went to a clear spot, 12,000,10,10 far enough away from the existing builds.
timestamp 2014-7-21T 00:13:25

I ran the particleBirds.js at default settings, the particles worked, but then a phantom voxel appeared, the particle birds finished but then colored cubes began appearing randomly around me, at random sizes, also the particle birds sporadically appear in a burst of several spheres, then disappear after less than one second.

This was a clear spot, and I did not create any voxels.
Several minutes after the script supposedly stopped the cubes are still there see pic,
some are even nested see the green and yellow one.

THEN SUDDENLY THIS


I have no idea how big this thing is but the red arrow points to my Bender avatar, so that gives you an idea of scale.

This thing is still phantom, doesnt register as a voxel.

Glad I went out of town for this experiment.

This big one persisted while I moved 8,000 away and I could still see it, I turned and turned back and it was gone.


#4

I don’t see it as “megavoxels” spawning everywhere…
Whenever I am working in the sandbox (especially when working with megatiny voxels) and the larger cubes show up, it’s usually an issue with the LOD for me.

So what you can do is, if this happens again, check under Developer>Rendering Options>LOD Tools … and the menu that comes up can help you change the level of detail in the area. Try pulling them all the way up and see if things go back to normal.

I really do wish that the LOD would not automatically fix itself, though… Even when I un-tick the Automatic Avatar LOD Adjustment function… the LOD Size Scale keeps derezzing everything after a while.

@chris I’ve never posted in the jobs list before, but I would think this is something that definitely needs to be worked on.


#5

Thanks for the suggestion @Krysania but changing LOD settings is having no effect on the problem, I see the background sandbox changing detail but the problem remains the same.

Today I have tried higher LOD and lower LOD and the problem continues, I am back to stage 2 where everytime I run the script I get one single frame of particles, then they go away, the particleBirds dont function anymore and the cubes persist popping in and out various sizes and colors.

I am trying to work this script but it is impossible under the current conditions, I hope someone can help, I dont even know how to describe the problem simply enough to create a worklist job, not sure where the problem lies.


#6

Hi @Adrian can you tell me your exact setup? I am trying to reproduce your issue.


#7

@chris Windows7 Pro. 6.1.7601 service pack 1 (64bit)
Intel core i7-4930k cpu 3.40GHz 3701 MHz 6 cores 12 logical processors 16G ram(2400MHZ DDR3).
graphics - MSI N760-TF-4GD50C GTX760 4GB GDDR5 DP HDMI 2DV1PC1e3 0
Hifi build 892.
All tests were done in the sandbox at various location


#8

I have been trying several times today to replicate the problem and it is not occurring.
Occasionally I get a random cube appear but it goes away.

I am thinking it may have been a glitch in the particle server, all the phantom cubes I saw yesterday are gone.
I have a feeling the particle server was restarted.

I have been modifying the script params a little, and the script seems to be rock solid, the particle server is behaving today, I am going to continue my mods to this script and closely watch the results.

All I can point out now is that the bird sounds are failing to load (error downloading sound) but I can work without these sounds, I might comment them out to reduce console spam.

I am now sorry I used the word MegaVoxel, because it is clearly not our familiar megaVoxel bug.
I must talk to @Judas he came to the location yesterday, I wonder if he saw any of these big cubes?


#9

I saw some i think buckyballs flickering about but no mega voxels of the size you spoke of


#10

It feels like sometimes the octtree gets stuck: I’ll often see situations where I’d placed a bunch of small voxels in an area and when I come back later, some chunks have been persistently replaced by a large voxel, as though that one chunk is at a lower LOD than all the surrounding ones.