Metavoxel terrain not saving


#1

@chris this issue we touched on when we spoke is still happening for me.
Did some tests, @Coal tried the same files from his end on my domain and it worked without problem so something to do with my end.
Maybe it is to do with my slow upload speed?
It is a bit different now because I dont even see any activity on the in or out meter at the bottom right of interface when I save.


#2

@Adrian Intressting, i cannot believe its uplaod speed. because High Fidelity have already the map if you can see it. It start to save when you press apply. But not tried it with the latest builds.

But, dont close the metavoxel window to soon, i expect that things then get wonky and not stored. I have seen it a while ago to that terrain is not saving, and i think its having todo with how fast you close the metavoxel editor.

Also it can take a while before the terrain appears when you have closed the metavoxel editor. If i need to test something, just shout.


#3

So the terrain saving works when it is done from outside the network, but not from a local lan ?


#4

Mine is running on local lan, going to test it right now.
On problem i still see when you try to save the terrain. lots and lots of

But at the end the terrain is saved for me. But it takes a very long time to save it.


#5

It’s past time something was done to stop loss of proposed metavoxel insertion due to (not realizing) it’s too soon to close editor window.

https://worklist.net/20291


#6

I can close the metavoxel editor pretty fast, but because all checking and looking in windows its at least 10 seconds later before i hit the [X]


#7

Those of use accustomed to waiting, being patient so we don’t lose work or watching to see if network upload traffic has decreased know when it’s safe. It’s not reasonable to expect all will know that or always wait long enough. It’s an issue that needs addressing for a less alpha like experience.


#8

I will say this, I was was on screen sharing Skype with @Adrian when we worked on testing the upload of his terrain and while on mine I would get no errors and it would get and save the data to load in the metavoxels. When he tried it would give an error even if he sat there with the window open until the upload meter went down to its normal amount.

We tested this on his domain and mine and got the same results so speed did have something to do with it, at least something networking did.

This part is not 100% true because the system shows you on your local system a preview before it is uploaded. You can apply any size and work with it and it will show you what you are doing in this preview time.

It is not until you hit Apply that it actually does the uploading of this information and it is written into place. You know its written into place when your assignment-client spits out that it wrote to the metavoxel.dat file.


#9

Secondlife and Opensim spoiled me :wink: But your right high fidelity is doing lots of things client side. That also explains why its still slow for me to local to other server but with upload cap.

You would start to think that the time-out is kicking in before the upload is finished to the server.