Missing Config.json File


#1

Ok, after chatting with @Chris and re-watching his bot video, I now have it all figured out, however, when I run assignment-client.exe -n 15 -t 2 -a localhost, it runs the assignment client instances, but I’m getting the error:

Could not find JSON config file at: “C:/Users/John/AppData/Local/High Fidelity/Stack Manager/resources/config.json”

I understood @Chris’ video up to the point of running the assignment client, but the thing is I couldn’t find it, after browsing the forums, I found out where it was located, but when I go there and run the 15 instances for the bots, I get that error.

I’ve been around a long time, before Windows even, so I cut my teeth on DOS and command prompts and I’m very comfortable using them, so I’m sure I’m doing it right. I searched both of my hard drives for config.json, and I found one in the interface folder where the interface is installed and that’s it. Neither the stack manager folder (where the stack manager is installed) or the application data folder (where assignment-client.exe is installed) contain a config.json.

Any ideas?


#2

I suppose you have to create the file yourself.

It is used for setting a password to safeguard the http://localhost:40100/ url

https://alphas.highfidelity.io/t/restricting-access-to-your-domain-server/747


#3

Thanks Marcel, that solved the json issue, but I still can’t get the bots running, it’s throwing an error saying it can’t delete a cache file.


#4

Well thats indeed something i like to see or know how, safegaurd some pages
Let me look at the link


#5

@Richardus Take a look at this link…

https://alphas.highfidelity.io/t/restricting-access-to-your-domain-server/747

It shows how to put it together.


#6

Did that already, placed the file in the user hifi dir under resources. but… no password window. *c:\Users<username>\AppData\Local\High Fidelity\Stack Manager\resources* So, something not working i dont get the auth dialog in my webbrowser.

Note: i dont use localhost.


#7

Odd… I get the authorization window and it takes my password to get through. you put it in %USERPROFILE%\AppData\Local\High Fidelity\Stack Manager\resources\ ?


#8

Yes doubvle checked it again. its not working. i type my :40100 and i just get the screen am always seeing.


#9

I have gone through the process on Windows. The biggest issue is potentially the bot script I put in my previous post had an issue, this is now corrected. config.json is not necessary to get things going.

Here are the steps.

1- Start your Stack Manager

2- Go to http://localhost:40100 and you can see that it is running.

3- (in Windows) Open up a command prompt and navigate to: (replace dev1 with your username).

4- Go to http://localhost:40100/assignment and copy in the text from the folllowing file: http://highfidelity-public.s3-us-west-1.amazonaws.com/scripts/bot_procedural.js . In the top right hand box “# of instances” put in 3 and click “Run”

5- If you go back to http://localhost:40100 you will now see three “Queued Assignments”

6- Go back to your command prompt and type: assignment-client.exe -n 3 -t 2 -a localhost

7- Launch Interface and go to: File>Go to Domain “localhost” and File >Go to location “0,0,0”

You should then see 3 avatars walking around.


#10

json script is needed to close the access to the web console. and i like to have that closed. But its not working here. did what is told in this topic to set a user and password. but get complete ignored and when i login with webbrowser to the hifi server on local network with domain name i use for it. no login dialog.


#11

@Richardus correct json is needed to lock it down, for running bots it is not. If you want to add the Config.json for a username and password copy and paste this:

{
“basic-auth”: {
“birarda”: {
“password”: “secretpassword”
}
}
}


#12

And now it works, only difference the whole server where powered down and now started.
But it seems your not allowed to use a tab etc. to create spaceing so its more readable.
so the code the view here enter link description here. failed for me because the tabs. could not test it more because i cannot close the viewer right now. (cache)

But it works now, thanks @chris.