Missing .dlls in Stack Manager


#1

Yesterday I again added the audio AC script to the Capitola domain to see if it was fixed yet. It was not. This morning the sound was gone.

I did a normal shut down of the server and closed the SM. Then tried to restart it but after doing the update it would not start. I got error message saying “Missing .dll msvcp120.dll. Can not start program.” or something like that.

So, emailed the .dll to the server, stuck it where it should have been and tried again. This time I got “Missing .dll msvcr120.dll” etc. After I copied in the second missing .dll, the Stack Manager started and all is back to “normal” now.

Before I fixed the Capitola domain I tried starting up a different one on my local machine here and it worked fine. But the local machine has lots more software installed on it that use those .dlls including c++ and VS etc.

Just a warning to everyone this weekend. If you can avoid it, don’t restart your win Stack Manager unless you are willing to possibly fix it by hand. Maybe on Monday this will get fixed.


#2

Those two DLLs are are part of the Visual C++ Redistributable Packages for Visual Studio 2013, and it seems odd they would go missing unless this is yet another artifact of the 32-bit to 64-bit transition.


#3

I had the same thing missing the other day 2 when i was reinstalling windows


#4

That’s a common returning problem with high fidelity. it’s not installing teh correct redistrubtial when it’s missing on the system. It’s while ago i have seen that error. Will keep eye on it with next stack-manager update.


#5

I suppose all eyes will be on the console and getting that ready.


#6

My recommendation, to understand the issue, is that when you run into the missing DLL problem, download the visual studio package (using the link I provided in my previous response). Install just the 64-bit package and see if that fixes things. If this is a general issue it is one derived from 32-bit only development. My WAG is that when the builds were all 32-bit, it is possible that their installer was bringing in only the 32-bit VS package but that now that there are 64-bit components, the installer scripts are not checking for the 64-bit VS package… Depending on what happens to be installed in our computers, we might already have the 64-bit VS 2013 package, which is why it works for some of us. It’s common in 32-bit installer scripts to have something like this:

//Will Install 32 bit only.
    if (target_x86_only = True) then begin
        if NOT VCVersionInstalled(VC_2013_REDIST) then
           AddProduct('vcredist_x86.exe',  
              CustomMessage('vcredist2013_lcid') + '/install /quiet /norestart',
              CustomMessage('vcredist2013_title'),
              CustomMessage('vcredist2013_size'),
              VC_REDIST2013_URL,
                false, false);
     end;

#7

I found that installing the VS redistributable package was not enough. I even already had the missing .dlls in my setup. I had to install the Stack Manager explicitly running that installer as administrator level. So maybe there is some pointer or manifest that is not correctly being update din the current installer.


#8

WIch VS redistributable did you install ? the 32bit or 64bit ? I run Stack-Manager expliciet as user account. Updating works. But a fresjh installation i think requires admin rights.


#9

It was a fresh install… but I did not see anything that indicated admin level run was needed… and also no indication that the installer was only 64 but.

I was moving the domain onto a server that was 64 bit to get round that bug on my previous 432 bit Windows 10 setup.


#10

HI,

There will be an update to controlling your server with a new program called “Console”, it should be released very shortly. In the meantime you can install the 64bit version from here: https://www.microsoft.com/en-eg/download/details.aspx?id=40784

Chris


#11

The Server Console is now available - https://alphas.highfidelity.io/t/high-fidelity-server-console/10088/5