Mixamo rig and skinning does not work on HiFi


#1

For over a month I have been trying to upload a rigged avatar onto HiFi with no luck.
I thought I was the only one then I realized other people are having the same problem.
It does not make logical sense considering HiFi already have a limited number of rigged avatar for the mixamo software to be malfunctioning when people try to make new avatars. I am sure I was told Mixamo rigged characters match the HiFi rig.
When uploaded the characters do not react well to the scripted animation. You have to turn off the walk animation and then your character is stuck in the pose that you uploaded it in.

The characters animate well in mixamo but not so in software like Blender and 3ds Max.
The skinning does not look right and the characters skeleton size does not match that off an animation skeleton. ( I could only animate FBX file in 3ds Max.)


#2

Doesnt work for me either, except my issue is the avatar is invisible when i upload it to the maximo site and try to rig it.


#3

Yeah despite what (adobe) Mixamo says, the free rigging doesn’t actually work at all. Sure you’ll have a skeleton but it won’t work unless you pay for the software.


#4

I would be quite happy to have a skeleton I can work with. However the packaging tool has changed since the Hi-Fi team made the avatars that we all use. The tool does not highlight any errors one might make as they package their character. You only get an error message after loading the FST URL. This means you can waste up to half an hour exporting and uploading your character only to get the default robot.


#5

Are you sure your avatar is not visible in maximo? Have you tried rigging one of their free characters.


#6

We nailed down the problem with animating avis exported from Blender yesterday - the beta walk script now has a (temporary) fix that can be selected in the settings. Please see here for instructions and more details: https://alphas.highfidelity.io/t/walk-js-new-avis-physics-and-turn-detection/5460/39

The beta walk script is here: https://hifi-public.s3.amazonaws.com/procedural-animator/beta/walk.js

Any feedback very much appreciated!

  • davedub

#7

My problem is I spend a lot of time rigging either in Blender or 3ds Max only to find my characters are stuck in the T pose when I upload them to Hifi.
As soon as I give up making characters the ready made Hifi characters stop responding to arrow keys.
So I am not particularly keen to see if the Hifi characters walk with new JS: I want to know how to make sure my characters will animate.
Thanks for the offer to help.


#8

If your characters are stuck in T-pose, it means two things:

  1. Either thats the pose you exported them from Blender, to which there is a very simple fix:
    https://www.youtube.com/watch?v=e7LvjAH8bw4
    This is the default pose your avatar will be in if not animated.
    (ill update this later to give more info on what to fix to make sure that the avatar stays up right with the walk script)

  2. The animation script simply is not on:

  3. it means that the skeleton names or structure is not correct: See bone structure from https://alphas.highfidelity.io/t/avatars-standard-compendium/6200


#9

Thanks I will look in to that. So this just changes the pose but does not allow the avatar to be animated. Hmmm I guess I will have to live with that.


#10

You can still animate the avatar after it, its the pose you set here is the one it will assume if the avatar is not being animated.

You have to run the animations separate via the Edit> Animations, or run a script, such as the walk.js to animate the avatar.


#11

Thank. Now I need to make a clean installation. It does not matter which version of Interface I go back to my avatar is constantly in one place.


#12

Was going to reply to you on the youtube page, but I think its better to keep the comms here so that every one sees the solutions:

The walk script scrambling the avatar is a documented bug with models made in blender and imported in High fidelity. You can see this specific post on it https://alphas.highfidelity.io/t/ultimate-blender-compendium-woes-of-the-blender-fbx-export-at-the-mountains-of-documentation-madness/4739/48

The suggestions here have now been implemented in the beta version of the walk script which,
@davedub has been working on. So far, this works great (it requires you to change the settings to apply blender rotations) Try give it a try: https://hifi-public.s3.amazonaws.com/procedural-animator/beta/walk.js (Post https://alphas.highfidelity.io/t/walk-js-new-avis-physics-and-turn-detection/5460/39 ) Hopefully that helps.


#13

Thanks but I have remove Hifi completely from my system and take a break from HiFi before I go mental


#14

OK I have solved this issue. For some reason I was saving my players created in Fuse as FBX files and not Unity FBX.
Using Fuse to create player is the quickest way to get going. My next experiment is to create my own player and use Fuse to do all the rigging. I believe I only get 9 attempts.