Models won't load


#1

Two issues:

  1. Previously, I was able to upload a simple, untextured cube to local
    server, Sandbox and Earth and all seemed well, but found out from
    @Adrian that the model was throwing continuous error messages to
    the server log. (Lesson: monitor the log when you do anything new.)
    Some weeks later I tried to do some tests to troubleshoot, but now…
  2. I am now unable to get even the simple cube or any other model to
    load

Files located on Web servers at
http://simulacron3.github.io/1mat_copy_embed.fbx, http://simulacron3.github.io/treeBam.fbx
(1mat_copy_embed.fbx is a test file I created; treeBam.fbx is a file known to work and was copied from the hosting site)
and
http://104.236.159.199/models/1mat_copy_embed.fbx, http://104.236.159.199/models/treeBam.fbx
(this is on my own server on DigitalOcean)

Access confirmed by pointing Web browser to the file (files do download)

When I try to upload to HF, I get the Failed to load error.

Any clue you can provide will be my much-appreciated first.


#2

I have uploaded your model http://104.236.159.199/models/treeBam.fbx at MagicGame and it has worked, only there were no textures.


#3

This one http://simulacron3.github.io/1mat_copy_embed.fbx is showing me after download nothing in blender. file is also only 4KB in size. So textures are embedd.

http://simulacron3.github.io/treeBam.fbx is bigger, and showing in blender. but the texture is just simple black… textures are missing or corrupt.

Same for the other 2 links, the are grey or not showing in blender and the fbx viewer. something looks wrong with the textures.

I can upload the http://simulacron3.github.io/treeBam.fbx fine.on my domain.


#4

Thanks much for the info.

The tree file probably has a texture that I didn’t get from the original source, as I just grabbed the file to test against a problem with the box file that I created myself, so that is probably normal behavior.

The box is just a cube made in Blender with a single material and exported to fbx with embed and copy settings.


#5

Thank you.

I guess I do have two problems: why uploading fails for me but not you for both files and servers and why my cube doesn’t work as expected.